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Exercise 1: Working as an Operator in IGSS  

We want to see how a completed IGSS SCADA system appears to plant operator 

personnel to get an idea of the various elements in the system and how they 

work. Therefore, in the following, we assume the role of an operator and perform 

monitoring and control tasks. 

30 - 45 minutes. 

Start the Demo Project  

The IGSS project we will be monitoring is called the Demo project which is 

installed automatically when the “Demo system” option is chosen during 

installation. 

The Demo project will be the foundation for the next few exercises until you will 

be creating your own project and populating it with objects, diagrams and 

elements of your own. 

Now let’s go online with the IGSS system and the Demo project. 

 

Step Action 

1.  Start IGSS from the Start menu in Windows or click the IGSS icon on the 

Windows desktop.  

The IGSS Master opens. 

2.  In the IGSS Master, click the Start button. 

 

3.  Click the Supervise button to activate the Supervise module. 

Contents 

Duration 

Purpose 

Task 1:  

Load and start 

the Demo 

project 
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Online in Runtime  mode  

To learn how to monitor and control different types of IGSS objects. 

We need to locate the object named q3, which is located somewhere in the plant 

mimic diagram but we don’t know exactly where. 

 

Step Action 

1.  Locating the object named q3: 

In the menu, click Edit > Open by Name to open the Object Browser form. 

2.  At the bottom of the Object Browser form, select the Advanced checkbox to 

expand the form with additional fields.  

Under the right pane, in the Wild card text criteria field, enter “q*” as search 

criterion.  

All objects starting with the letter q are displayed in a list in the right hand pane 

of the form.  

 

 

 

Purpose 

Task 1: 

Change alarm 

limits 
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3.  In the list, select the q3 object.  

In the Open by name  group, clear the Show properties  checkbox and click the 

Open/Select  button  

The diagram where the q3 object is located is opened and the object is displayed 

with an animated line around it. 

4.  Click directly on the name q3 to bring up the object’s command menu. 

Select the HA (High Alarm) setting and enter “80ò, and click the OK button. 

Click q3 again to see the result of your change. 

5.  Right-click the q3 object and select Properties  to open the q3 properties form. 

Click the Analog  tab  

In the High Alarm  field, change the value back to the original setting of 88. 

Click the OK button to finish. 

 

You now need to stop the pump (p1) in the mimic diagram. You do this by 

locating the pump in the mimic diagram first and then send the STOP command 

to the pump through the p1 object. 

Step Action 

1. Find the object p1 in the same way you found the q3 object above.  

2. You can send the STOP command in the following ways 

In the Refuse disposal plant mimic diagram: 

¶ Click the STOP button under the p1 text 

¶ Right-click the p1 object and select STOP. 

¶ Right-click the p1 object and select Properties. 

o Click the Change State tab and select STOP in the Commands 

field. 

 

Task 2:  

Send commands 

(digital object) 
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Alarm Handling  

To learn how to: 

¶ Acknowledge alarms in both the Active  Alarms  list and on the object name in 

the mimic. 

¶ Find objects in the mimic diagram that are in a state of alarm. 

¶ Create alarm list filters 

¶ Customize the alarm list 

First you need to find and acknowledge the presently occurring alarms in the 

demo project by opening the alarm list in the Active Alarms form. 

 

Step Action 

1.  Find the object q2 and acknowledge its alarm. This can be done in five different 

ways: 

 

From the mimic diagram: 

1) In the mimic diagram, right-click the object name or object symbol to 

bring up the command menu, then left click and select Acknowledge 

Alarm. 

 

From the Alarm List in the Active Alarms form: 

2) Double-click on the square shaped alarm icon appearing on the process 

picture to go into the Alarm List in the Active Alarms form, find the 

object name, right-click on it, then right-click again on “Acknowledge”. 

 

3) Open the Alarm List in the Active Alarms form by clicking on Active 

Alarms in the task bar at the bottom of the screen and follow procedure 

in (2) above. 

 

4) Open the Alarm List by clicking on the small square shaped icon on the 

system tray at the bottom right hand corner of the screen ( ) and 

follow procedure in (2) above 

 

5) Open the Alarm List from the IGSS Master, click Home tab > Alarm 

button and follow procedure in (2) above.  

 

Purpose 

Task 1: 

Acknowledge 

alarms 
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There are many alarms in the alarm list and we need to filter the alarms to display 

the alarms we have an interest in monitoring. Right now we want to filter alarm 

list to display all objects that start with ”q”. 

 

Step Action 

1.  Open the  Active Alarms  form (See step 1 in Task 1 above for the method to 

open the Active Alarms form)  

Tip: 
If the left pane is hidden, you can expand the pane by selecting it with the mouse 

cursor and dragging the pane to the right. 

2.  In the tree view, select the Active Alarms folder. 

 

On the Active Alarms menu, click Customize >  New Filter to create a filter. 

 

In the Filter name field, enter “Flow Gauges”. 

In the Property field, select “Object name” 

In the Condition field, select “begins with” 

In the Value field, enter “q” 

Click the Add button to add the new filter. 

Click the OK button to create the Flow gauges filter and place it under the Active 

Alarms folder in the left pane. 

3.  Click the Flow Gauges filter to see the filter’s results in the list pane to the right 

of the form.  

 

 
 

 

Task 2:  

Create a new 

alarm list filter 
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You can also customize the alarm list that is displayed in the right pane, selecting 

which columns are to be displayed and their sorting order in order to increase the 

overview granted by the alarm list. 

We need to display the following information in the alarm list: 

¶ S.No. 

¶ Area name 

¶ Object name 

¶ Description 

¶ Alarm number 

¶ Alarm text 

¶ Priority 

¶ Value 

¶ Start date 

¶ End date 

¶ Acknowledge time 
 
We are not interested in the rest of the columns in the alarm list and should 

remove them from the alarm list. 

Step Action 

1.  Select the Flow gauges filter under the Active Alarms folder in the left pane of 

the Active Alarms form.  

2.  Click the alarm list in the left pane. 

3.  Click Customize > Alarm List Format to open the Alarm List format form. 

4.  In the All Columns group, select Object Name and click the Add button to add 

the Object Name to the alarm list display. 

5.  Repeat step 3, adding Value to the alarm list display. 

6.  In the Columns Displayed group, select Start time and click the Remove button 

to remove the Start time from the alarm list display. 

7.  Repeat step 5 until you have only have the 11 columns displayed you want. 

8.  Click the OK button to save the column display. 

9.  Move the columns up or down by selecting the column you want to re-arrange 

and clicking the Move Up or Move Down buttons. 

10.  Select the Flow gauges filter under the Active Alarms folder in the left pane of 

the Active Alarms form.  

Task 3:  

Customize the 

alarm list  
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11.  Click the alarm list in the left pane. 

12.  Click Customize  > Set Sort Order to open the Set Sort Order form. 

13.  In the Sort group, select the object and the Move Up or Move Down button to 

create the sort order below: 

1. Priority  

2. Area Name  

3. Object Name 

14.  In the Sort group, select  

¶ Priority and select the Descending option 

¶ Area Name and select the Ascending option 

¶ Object Name and select the Ascending option 

15.  Click the OK button to return to the alarm list. 

16.  Try changing the sort order and the ascending/descending sort direction for 

other columns to see what happens. 

Note that all columns are listed in the Set Sort Order form, even the columns 

that are not to be displayed.  

Try changing the sort order of some of the columns not displayed. 

 

You can also inhibit objects from triggering an alarm, suppressing the alarms 

generated by that object as well as adding an alarm note to the object alarm. 

Alarm notes are used to inform others as well as yourself of events and important 

information concerning the active alarm. 

We are going to inhibit the alarm of the q1 object and insert an alarm note that 

explains who inhibited the alarm and when. You can inhibit an alarm on an object 

by right-clicking on the object in alarm list or on the object itself in the Supervise 

mimic diagram. 

First, we have to locate the q1 object though. 

Step Action 

1.  Click IGSS Master > Home > Supervise to open the Supervise module  

Task 4: 

Inhibit alarms 

and alarm note 
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2.  Locate the object q1. (See  Exercise 1: Working as an Operator  in IGSS 

Online in Supervise mode , steps 1 to 3 for a reminder on how to locate objects 

in the Supervise  module) 

3.  Right-click q1 the object in the Dairy mimic diagram and select Inhibit alarmsé. 

to open the Inhibit Alarms form 

In the Inhibit Alarms form, select the Inhibit only individual alarms on the 

object as selected below checkbox. 

In the pane below, select the first alarm checkbox only. Leave any other alarm 

checkboxes cleared. 

You have just inhibited the one of the alarms on the q1 object. 

Click the OK button. 

Note 
You can also locate the object directly through the Alarm List in the right pane of 

the Active Alarms form by right-clicking on the object in the Alarm List and 

selecting Find. 

4.  Open the Active Alarms form (See step 1 in Task 1 above for the method to open 

the Active Alarms form) 

5.  Find q1 in the Alarm List in the right pane of the Active Alarms form and find the 

inhibited alarm. 

6.  Right-click on q1 in the Alarm List and select Noteé 

Click on the Alarm Note tab and in the input field (the white field underneath 

the dimmed Description field) enter “I inhibited this alarm <your 

initials><date> .” 

Click the OK button and verify that the note icon (  ) is displayed to the left of 

the q1 object line in the alarm list. 

 

Tip 
You can also attach a note to an alarm on an object by right-clicking the object in 

the Supervise mimic diagram and select Alarm Text.  

You can enter an alarm note on the Edit Alarm Note tab in the Note group. 
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In addition to attaching a note to the alarm on an object, we can create and 

attach a note on the object, registering important information regarding the 

object independently of any occurring alarms. 

 

Step Action 

1.  Click IGSS Master > Home > Supervise to open the Supervise module  

2.  Locate the object q4. (See  Exercise 1: Working as an Operato r in IGSS Online 

in Supervise mode , steps 1 to 3 for a reminder on how to locate objects in the 

Supervise module) 

Note 
You can also locate the object directly through the Alarm List in the right pane of 

the Active Alarms form by right-clicking on the object in the Alarm List and 

selecting Find. 

3.  Right-click the q4 object in the Supervise mimic diagram and select Object note .  

In the input field (under the dimmed By User field) in the Note group, enter in 

the message “I have a message about this object for operators 

on duty.ò 

Click the OK button. 

4.  Open the Active Alarms form and find the q4 object. 

 

(See step 1 in Task 1 above for the method to open the Active Alarms form) 

Task 5: 

Create Object 

Note 
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5.  In the Alarm List in the right pane, find q4 and observe how it looks.  

¶ Verify that the note icon (  ) is displayed to the left of the q4 object 

¶ What alarm number does the alarm have? 

¶ Note color of the line in the alarm list 

 

6.  To remove q4 from the Alarm List, go back to the object and bring up its Object 

Noteé again and click the button Terminate . 

 

Note 
The alarm text and font colors are set up in the Definition module in the Alarm 
Details form found in Edit > Alarm Texts. Creating new alarm texts and editing 
existing alarm texts are detailed later. 
 

We now have to remove the object note from the q4 object and see what 

happens to the alarm list and the alarm log.  

 

Step Action 

1.  In the Active Alarms form, locate the q4 object in the Alarm List in the right pane 

of the Active Alarms form. 

Note the alarm number of the alarm line with the q4 object note. (hint: The 

Alarm number is 96 and the alarm text is “Object note attached” 

2.  In the Alarm List in the right pane of the Active Alarms form, right-click the q4 

object and select Find. 

The Supervise mimic diagram is opened and the q4 object is marked with an 

animated symbol. 

3.  In the Supervise mimic diagram, right-click the q4 object and select Object note .  

In the Edit Object note tab, click the Terminate button. 

The note text in the input field under the dimmed By user field is cleared. 

Click the OK button. 

4.  Open the Active Alarms form and find the q4 object again. 

Verify that the alarm for the q4 object list with the object note icon is not longer 

displayed in the alarm list in the right pane of the Active Alarms form. 

5.  In the left pane, click the Alarm Log folder to open the alarm log and create a 

new filter to locate the q4 object. 

 

(See Task 2: Create a new alarm list filter above for instructions on how to 

create and edit filters.) 

Task 6: Remove 

Object Note 
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6.  In the alarm list in the right pane of the Alarm logs, use the alarm number from 

step 1 above and find the alarm line that was created when you attached an 

object note to the q4 object. 

 

Tip 
You can sort the entries in the Alarm List by clicking on the header of the column 

in the Alarm List. You can also create a new sort order for the filter if you want. 
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Working with Graphs  

Learn how to: 

¶ Open predefined graphs 

¶ Create and open dynamic graphs 
 

You can view the data which your objects in the Supervise mimic diagram 

collect during operations through graphs you can define and save for re-use 

(predefined graphs) or through graphs you create and use at the time you 

need them. .. “on-the-fly” so to speak. (dynamic graphs)  

First, we will open and view a predefined graph. Then you can create your own 

dynamic graph. 

The predefined graphs used in this exercise have been created for the demo 

project.  You will be creating your own graphs and using them as predefined 

graphs in a later exercise. 

 

Step Action 

1.  In IGSS Master > Home tab, click the Start button to start the demo. 

Click the Supervise button to open the demo diagram. 

In the menu  of the Supervise mimic diagram, click Area > Cases 

In the menu of the Supervise mimic diagram, click Graph > Water Supply Total 

Extractions. 

The Water Supply Total Extractions graph is displayed. 

2.  In the Water Supply Total Extractions graph, right-click and select Show Values 

List to get an overview of the values used to draw the graph lines. 

Click the Close button to return to the graph. 

3.  Select an area in the Water Supply Total Extractions graph with the mouse 

cursor. You can select an area when the mouse cursor changes to a crosshairs 

icon. 

The selected area zooms in and displays the graph and values. You can zoom out 

by right-clicking the graph and selecting Rezoom. 

Purpose 

Task 1:  

Open a  

predefined graph 
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4.  Right-click in the Water Supply Total Extractions graph and select Edit 

parameters to open the Define Graph Parameters form. 

In the Define Graph Parameters form, click the BCL option in the Source group 

to change the data source for the graph from LOG to BCL. 

Note the change in “index” due to the change in data source. 

Click the OK button. 

5.  Open the Define graph parameters form and experiment with the layout of the 

graph window (e.g., suppress some of the y-axes, change background colors and 

filling patterns, etc). 

6.  Close the Water Supply Total Extractions graph, but remain in the Cases area. (in 

the menu, click  Area and verify that the Cases option is still selected) 

 

 

 

You can also create a dynamic graph, defining the requirements and display 

options as you need them.  

In this exercise, you create a new dynamic graph and save it for future use, both 

as a dynamic graph and a static graph and then retrieve the saved graph for 

display on the screen. 

 

Step Action 

1.  On the menu, click Graph > Create Dyn amic Graph  to open the Object 

Selection for Dynamic Graph form. 

Task 2:  

Create a  

dynamic graph 
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2.  In the Show Standard types objects list on the right, select : 

¶ q1 and click the Add  button.  

¶ q2 and click the Add  button. 

¶ q3 and click the Add  button. 

Click the OK button to open the Define Graph Period form. 

3.  In the Begin Time  field, in the Define Graph Period  form, set the time to 

display one hour ago.  

Click the OK button. The graph for the values for the q1, q2 and q3 objects is 

displayed. 

4.  Right-click inside the graph and select Save As Dynamic Graph,   

In the File name field, enter “Flows.usrò and remember the file location in the 

local machine’s hard drive  

Click the Save button and close the graph window by clicking on the X at the top 

right of the form. 

5.  In the menu, click Graph  > Open Dynamic Graph  and open the Flows.usr graph 

you just created. 

In the Begin Time  field, in the Define Graph Period  form, set the time to 

display one hour ago and click the OK button. 

The graph is displayed. 

6.  Right-click inside the graph and this time select Save As Static Graph  

In the File name field, enter “StaticFlows.gphò and remember the file location in 

the local machine’s hard drive  

Click the Save button and close the graph window by clicking on the X at the top 

right of the form. 

7.  In the menu, click Graph > Open Static Graph  and open the StaticFlows graph 

you just created to display the graph. 

 

YOU HAVE SUCCESSFULLY COMPLETED THE GRAPH EXERCISE. GO ON TO THE 

NEXT EXERCISE. 
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The Object Historian  

Learn how to view and save data for selected objects in the configuration. 

You can use the Object Historian to view past events in the monitored process, 

exporting the data if you desire for further processing in other systems.  

You select can view four different event types in the Object Historian: 

¶ Log data  

¶ Alarm data  

¶ BCL data  

¶ User login/logout 
 

 

Step Action 

1.  In IGSS Master > Home tab, click the Start button to start the demo. 

Click the Supervise button to open the demo diagram. 

In the menu  of the Supervise mimic diagram, click Area > Training 

Click the Refuse Disposal diagram 

2.  In the Refuse disposal diagram, select the p1 and p2 objects with the mouse. 

3.  In the menu, click Edit >Object Historian to open the Object Historian form. 

The two objects (p1 and p2) are displayed in the form, but we need to include 

the p3 object as well.  

4.  Click the Browse button to open the Object Browser from.  

Find the p3 object, drag it into the Object Historian form and Close the Object 

Browser. 

Tip 
See Exercise 1: Working as an Operator in IGSS Online in Supervise mode for 

instructions on how to locate objects in the Object Browser form.  

The Object Historian form should now contain three objects: p1, p2 and p3. 

5.  Click the Query Data button to gather the data for the three objects: p1, p2 and 

p3. 

The hōƧŜŎǘ IƛǎǘƻǊƛŀƴΩǎ main pane will be populated with the data observations 

for the objects: p1, p2 and p3. 

Purpose 

Task 1:  

Select the objects 

for which data is 

required 
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6.  In the Time interval group, set the start and end dates and the start and end 

time parameters to gather data from  

¶ One hour ago 

¶ 5 minutes ago 

¶ Only yesterday 

Click the Query Data button to gather the data with the start and end dates and 

times you defined above. 

7.  The Object Historian form displays log data, but you can change the type of data 

displayed in the Event Types groups. 

 Click the Export as CSV button to save the data presented in the Object Historian 

main pane as a comma-separated file. 

You can use the comma comma-separated file as input in other programs such 

as MS-Excel to create advanced tables and graphs or import the values in 

another database program to continue working with the values 

 Try to change the parameters in the Time interval and Event types groups to see 

the effects on the data gathered.  
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Exercise 2: Creating a New IGSS Project 

 

Learn how to create a new project from scratch in IGSS Master. We will set up all 

the stations in the system, the global parameters and configure the PLC drivers. 

30 -  40 minutes. 

You will now be creating your own project and populating it with objects, 

diagrams and elements of your own. 

The new project will be defined as an IGSS Server and operator station project 

and you will set up the server and define the project configuration. 

Later, you will create the mimic diagram and create the objects an symbols for 

the project. 

 

Step Action 

1.  In the IGSS Master, click Home tab > Stop button to stop the current project 

2.  Click the Application menu > Design Mode to switch to design mode. 

When IGSS is in design mode, the Design and Setup tab will be displayed in the 

IGSS Master. 

3.  Click Design and Setup tab > Project Wizard button and click the Next button to 

proceed. 

4.  Select Create a new IGSS project and click Next. 

5.  Assign the name “Exercise” to the project and save it in this location: 

C:\ IGSS\ Training Project. Click Next to proceed. 

 

Purpose 

Duration 

Task 1: Create a 

new configuration 

and set up an IGSS 

server. 
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6.  Select the Server station type and click the Next button. 

7.  Give the station the name IGSS_Server. 

8.  Click the New Driver button and select driver “7TS7TCP” in the list. The driver 

has the ID 72. 

Click the OK button. 

9.  Click the New Interface button. The text IPNetwork appears. This driver uses an 

IP connection to reach the PLC. 

10.  Click the New Node button to create node number 0. This is the unique identifier 

of the PLC. 

11.  Click the Next button twice to proceed as we want to also create an operator 

station. 

12.  Select Add an operator station and click the Next button. 

13.  Assign the name OP1 to the operator station.  

Notice that all other buttons are inaccessible out. This is because we’re defining 

a flat operator station with connections to PLCs.  

Click the Next button to proceed. 

14.  In the What is the IP address (or host name) of the primary IGSS Server? Field, 

enter the IP address of your computer. 

Tip 
Use the IPCONFIG command at the Windows DOS prompt to find your 

computer’s IP address.   

Click the Next button to proceed. 

15.  Click Finish to complete the wizard.  

The System Configuration module is opened (see the screenshot below). 
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16.  In the left pane, right-click the server and select This PC. 

 

Before you can continue, you must set up and define the global parameters for 

the project.  

You can do this using the various tabs in the System Configuration form. 

 

Step Action 

1.  Click the Configuration  tab. 

Verify in the display-only fields that you have loaded the correct project. This 

should be the project you created in the previous task. 

2.  In the following fields on the Configuration tab, enter the values: 

Scan intervals (msec) Log changes (%) Base intervals (min) 
2000 1 2 

5000 2 5 

8000 5 10 

12000 15 20 

Do not enter data in the other fields on this tab. 

3.  Click the Files  tab. 

 In the Log files  field in the Data size group, enter “72” to set enable the system 

to save the data from the log files for 72 hours. 

4.  Click the Access Control  tab. 

In the Access control group, select the Disable access control  checkbox. 

5.  Click the Alarm  tab: 

 

In the Alarm Settings group: 

¶ Select the Enable alarm blink in list  checkbox 

¶ Select the Display system tray icon checkbox 

In the Counter Group: 

¶ Select the Show non -ended alarm count  checkbox 

Task 2:   

Set up the 

global 

parameters 
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6.  Click the Supervise & Language  tab. 

In the Options group, select the following checkboxes: 

¶ Allow diagram move  

¶ Allow graph move and resize  

¶ Allow editing of graphs , 

¶ Enable inhibit alarms menu  

¶ Show active server name in  title bar . 

7.  Click the Startup tab. 

In the Startup group, select the Auto option. 

8.  Click the Data Collection tab 

In the Data Collection group, select the Run simulated check box. 

In the Advanced group, select the Validate input values against range checkbox. 

9.  Click the Reports tab. 

In the Headings group: 

¶ In the 1. Line field, enter “Training Plant” 

¶ In the 2. Line field, enter “Training Workshop” 

¶ Click the Browse button to the right of the Logo file field and navigate to 

C:\  ProgramData \  7T \  IGSS32 \  V9.0 \  GssDemo \  Images \  Icons \  

Icon_master.png, which is the graphic that will be shown when 

generating reports. 

Tip 
To find the Icon_Master.png file, remember to select All Files (*.*) in the drop-

down list in the browser window. The default setting is Logo files (*.bmp, *.gif, 

*.jpg) 

10.  In the System Configuration form, click the Save project  button ( ). 

11.  In the System Configuration form menu, click File > Save and Exit. 

12.  A dialog box is displayed to install your new project  

Click the Yes button to install. 
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13.  In the Installation Options dialog, keep the default settings and click the OK 

button. 

14.  An information dialog is displayed informing you that  

“Installation completed with no errors.”  

You have the option of viewing the project report, but we’re not interested in 

that right now.  

Click the No button to continue. 

 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE !! 
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Exercise 3: Create Areas and Diagrams in Definition 

 

¶ To learn how to create areas and diagrams (in Definition ). 

¶ To insert an existing graphic file as the static background picture for the 

diagram. 

10 - 15 minutes. 

 

After having created a new project and saved the set up parameters, you have to 

create the area where the diagram is to be placed and thereafter import the 

mimic diagram for the project as the project you just created is completely 

empty. 

You need to open the project in the Definition module and begin the actual 

construction of the process mimic diagram. 

 

Step Action 

1.  In the IGSS Master, Click Design and Setup tab > Definition button to open the 

Definition form. 

The Definition form is where you will be doing most of the work when you 

create or edit a project’s mimic diagram. 

2.  In the menu of the IGSS Definition form, click Area > Create to open the New 

Area Properties form. 

3.  In the New Area Properties form 

¶ In the Name field, enter: “Workshop” 

¶ In the Description field, enter: “Training Workshop” 

¶ In the Default Node field, enter: “0” 

¶ Select the Name to Menu checkbox 

¶ In the Default Driver field, select “7TS7TCP(IGSS_SERVER)” 

4.  Click the OK button to create the new area. 

You can verify if the new area exists and is selected by clicking the Area menu. 

The Workshop area should be selected in the Area menu. 

 

Purpose 

Duration 

Task 1: 

Create a new 

area 
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After having created the area which is to contain the mimic diagram, you must 

create the diagram.  You can create your own diagram, using external drawing 

programs and importing the diagram or create a diagram with a solid background 

color. 

For the rest of the exercises, we will be using the diagram depicted below and you 

will be importing the diagram in your project in this exercise. Later you will be 

creating objects and symbols for the project, placing them in the diagram. 

 

Task 2:  

Create a diagram 

Specify a default 

node and PLC 

driver for objects in 

this area 

Check this box to 

show the name in 

the Area menu 
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Step Action 

1.  (External workshops only) 

On the Workshop USB, navigate to the Training Files / Configuration Workshop 

/ENG / Course_Graphics folder. Copy all files in the folder. 

2.  (External workshops only)  

Go to the following location, 

C:\  Training Files / Configuration Workshop / ENG / Course_Graphics, and paste 

the files from Step 1. 

3.  In the menu in the IGSS Definition form, click Diagram  > Create to open the New 

Diagram Properties  form. 

On the Definition of New Diagram tab: 

¶ In the Name field, enter  ”Training” 

¶ In the Description field, enter “Workshop Project” 

4.  In the Windows Properties group, select the Name to Menu checkbox. 

5.  In the Background group, click the Browse  button to open the C:\  IGSS \ Training 

Files/Configuration Workshop / Eng / Course_Graphics folder. 

 

Select the Training.jpg  graphic and click the OK button. 
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6.  In the New Diagram Properties  form, click the OK button to import the 

background picture into the diagram. 

7.  In the IGSS Definition form, click Format  > Set Initial Display  to make this 

graphic the first one that appears at system startup.  

In the IGSS Definition form, click File > Check and Install to save the mimic 

diagram and to run a check of the diagram before installing it to the project. 

Tip 
You will be using Check and Install frequently and it is a good idea to remember 

the shortcut key (CTRL+T) for this function. 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE !! 
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Exercise 4: Creating IGSS Objects on the Process Diagram 

 

Learn how to create new objects for the mimic and how to use the copy/paste 

functions to replicate objects of identical nature.  

In the next exercise, we’ll learn to work with templates, which is another method 

for replicating objects with similar characteristics. 

We need to create the two flow gauges (analog objects q1 and q2) as well as a 

counter for the operational hours of the mixer motor (C1) and place them in the 

mimic diagram. We need to set up the alarm definitions and alarm texts for the 

gauges and the counter as well as set up the required connections and data 

collection parameters. 

We also need to create a color-coded pump symbol that quickly displays to the 

user whether or not the pump is running. 

Finally, as an optional task, we can create and define our own measurement units 

and assign the measurement designations to the relevant objects: The flow 

gauges and the counter (q1, q2 and C1) 

 

 30 - 45 minutes. 

 

We will create two analog objects and name them q1 and q2 which measure 

water flow. 

 

Purpose 

The Task 

Duration 

Task 1:  

Create the first 

flow gauge for 

the mimic.  

Position q1 

here 

Position q2 

here 
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Step Action 

1.  In the IGSS Master. Click Design and Setup tab > Definition button to open the 

Definition form. 

In the menu of the Definition form, click Area > Workshop. 

In the menu of the Definition form, click Diagram > Training. 

2.  In the mimic diagram, right-click the mouse at the position where q1 is to be 

placed (see above). Select New >Analog Elements  to open the Object Browser  

form. 

3.  In left pane of the Object Browser form, expand the Workshop  folder and select 

the Analog folders. 

Select the Advanced  checkbox to unfold the rest of the Object Browser form. 

4.  In the Create new object group, in n the Name field, enter “q1ò 

Click the Create  button to create the q1 analog object and to open the q1 ς Flow 

water in form displaying the q1 object properties (See below.) 
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5.  In the q1 ς Flow water in form , click the Analog tab 

¶ In the Description field, enter: “Flow water in” 

¶ In the Max. field, enter: “100” 

¶ In the Min. field, enter: ”0” 

¶ In the Decimal Point field, enter: “1” 

Select the High Alarm checkbox and in the input field to the right of the 

High Alarm checkbox, enter : “95.0” 

¶ In the Actual Value field, enter : “62.0” 

¶ Select the Low Limit checkbox and in the input field to the right of the 

Low Limit checkbox, enter “19.0” 

Note 
The Units field is left empty. The optional task at the end of this exercise explains 

how to set up measurement u nits and apply them to the objects in the diagram. 

The value in the Actual Value field is the initial value of the q1 object. 

After you have entered the description of the q1 object, the form changes name 

to q1 ς Flow water in. 

6.  In the q1 ς Flow water in form, click the Edit Mapping tab.  

In the Atoms group, clear the High Limit, Set Point, and Low Alarm checkboxes. 

7.  In the q1 ς Flow water in form, click the Edit Mapping  tab. 

Set up High Alarm properties: 

1) In the Atom group, select the High Alarm checkbox  

2) In the I/O Mode field select “Local” for the high alarm.  

3) In the Alarm Details  Group: 

a. Click the New button to open the Edit Alarm Description  form. 

b. Verify the value in the Alarm no. field is “101”. 

c.  In the Alarm text field, enter “High alarm on flow”  

d. In the Priority field, enter “10”  

e.  In the Instructions field, enter “Reduce inlet!” 

f. Click the OK button 

Set up Actual Value properties: 

1) In the Atom group, select the Actual Value  checkbox  

2) In the I/O Mode field select ñinò for the actual value. 

3) In the PLC Node for object q1 Group: 
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a. Verify the Driver:  field contains the PLC driver we chose in 

System Configuration  (7TS7TCP (IGSS_Server)  

b. Verify the Node:  field value is “0ò. 

c. In the Data Block Number field, enter: “6” 

d. In the Offset  field, enter: “0” 

e. In the Bit Offset field, enter: “1” 

Set up Low Limit properties: 

1) In the Atom group, select the Low Limit checkbox  

2) In the I/O Mode field select “local” for the low limit. 

3) In the Alarm Details Group: 

a. Click the New button to open the Edit Alarm Description form. 

b. Verify value in the Alarm no. field is “102”. 

c. In the Alarm text field, enter “’Low limit reached”  

d. In the Priority field enter “5”  

e. In the Instructions field, enter “Open inlet!” 

f. Click the OK button 

 

8.  In the q1 ς Flow water in form, click the Data Management Definitions tab. 

¶ In the Scan interval Group, select the 2000 option. 

¶ In the Logging Group, select the All changes option 

¶ In the Base interval Group, select the 10 option 

¶ In the Data Reduction Group, select the Average  checkbox 

¶ In the Transfer to History Group, select the Reduced value checkbox 

9.  In the q1 ς Flow water in form, click the Display tab. 

In the Show group: 

¶ In the Name sub-group, select the Enable checkbox. 

¶ In the State / Value sub-group, select the Enable checkbox.  

10.  In the q1 ς Flow water in form, click the Symbol Definition  tab. 

In the Choose symbol  group: 

In the Symbol table field, select Analog Elements and select the flow symbol 

(See below) 

Flow symbol: 
 

 

11.  Click the OK button to create the q1 analog object 

12.  Adjust the placement of q1 in the mimic diagram. 
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You have completed creating the first flow gauge, q1. 

Continue to create the next flow gauge, to be named q2. 

You can create the q2 gauge by copying and adjusting the already existing q1 

analog object. 

Step Action 

1.  In the Definition form in the mimic diagram, right-click the q1 analog object and 

select Copy . 

2.  Right-click the mimic diagram and select Paste  > As new object   

The original q1 is replicated but with a new name. q1_1  

(Why do you suppose this happens?) 

3.  Drag the new object to its correct position on the right side of the mimic (see the 

image above) 

4.  Right-click the q1_1 object and select Properties 

Select the Analog tab and in the Name field, enter “q2” 

Select the Edit Mapping  tab and select the Actual V alue  checkbox in the Atom 

group 

In PLC Address for High Alarm atom group: 

¶ In the Data Block Number field, enter: “6” 

¶ In the Offset  field, enter: “1” 

¶ In the Bit Offset field, enter: “1” 

(Why do you have to change the values in these fields?) 

This completes creating the two flow gauges q1 and q2.. 

 

Now we’ll create another type of IGSS object called a Counter  object. This object, 

called C1, will be used to count the operational hours of a mixer motor, which 

we’ll create at a later time. For now, we'll create the object and place it as shown 

on the diagram below. 

 

Task 2:  

Create the q2 

flow gauge 

object.  

Task 3: 

Create a counter 

object 
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Step Action 

1.  We will use a new graphical element to represent this object. 

In the menu, click Objects > Rectangular Field to open the Object browser form. 

In the Object browser form, expand the Workshop folder in the left pane and 

click on the Counter  form. 

2.  In the Name field, enter “C1” and click the Create button to open the object 

properties form.  

In the C1 object properties form, in the Desc. Field, enter “Operational hours for 

mixer“.  

The C1 object properties form changes name to C1 - Operational hours for mixer. 

3.  In the C1 - Operational hours for mixer form, click the Counter tab 

¶ In the Current count field, enter “100” as the default value of the counter. 

¶ Select the Limit checkbox and enter “150” in the input field to the right of 

the Limit checkbox 

¶ In the Preset value field, enter “15”.  

¶ In the Maximum value field, enter  “200”. 

Note 
The Units field is left empty. The optional task at the end of this exercise explains 

how to set up measurement u nits and apply them to the objects in the diagram. 

4.  In the C1 - Operational hours for mixer form, click the Data  Management 

Position C1 here 
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Definitions  tab 

¶ In the Scan interval group, select the 5000 option 

¶ In the Logging group,  select the >5 % option 

¶ In the Base interval group, select the 10 option 

¶ In the Data reduction group,  

o Select the Minimum checkbox 

o Select the Maximum checkbox 

o Clear All other checkboxes in the group. 

¶ In the Transfer to History group, select the Reduced Value option 

5.  In the C1 - Operational hours for mixer form, click the Display  tab 

In the Show group 

In the Name group, select the Enable checkbox. 

In the State/Value group, select the Enable checkbox. 

6.  In the C1 - Operational hours for mixer form, click the Edit Mapping  tab 

Set up the Command properties: 

1) In the Atom Group, select the Command checkbox 

2) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “24” 

b. In the Offset field, enter “1” 

c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the Count properties: 

1) In the Atom Group, select the Count checkbox 

2) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “23” 

b. In the Offset field, enter “0” 

c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the Preset properties: 

1) In the Atom Group, select the Preset checkbox 

2) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “24” 

b. In the Offset field, enter “2” 
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c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the Limit properties: 

1) In the Atom Group, select the Limit checkbox  

2) In the Alarm Details group 

a. Click the New button to open the Edit Alarm Description form. 

b. Verify the value in the Alarm no. field is “103”. 

c. In the Alarm text field, enter “’Counter limit exceeded”  

d. In the Priority field enter “10”  

e. In the Instructions field, enter “Use Auxiliary mixer” 

f. Click the OK button. 

7.  Click the OK button to create the C1 counter object. 

8.  In the mimic diagram, right-click the C1 counter object and select Properties  

9.  In the C1 - Operational hours for mixer form, click the Attributes of Rectangle 

tab 

In the Frame and Border group, select the Enable  checkbox  

Click the Settings  button to open the Frame/Border Settings   form 

¶ In the Frame/Border Settings  form: 

¶ Click the Frame Col or  button and select a dark red color. 

¶ In Frame Thickness  field, select or enter ò5ò 

¶ Click the OK button to save the border and frame settings. 

¶ Click the OK button to save the rectangle settings for the C1 counter 

object. 

10.  Place the C1 counter object in the mimic diagram as depicted above. 

 

Our next task is to place a simple on-off pump on the mimic diagram and 

represent it with a graphic from the Animated Symbol  library. 

Step Action 

1.  In the menu, click View > Drawing Toolbar to open the Drawing toolbar. 

2.  
In the Drawing toolbar, activate (click) the Animated symbol button ( ) and then click 

somewhere in the mimic diagram.  

Task 4: 

Attach a symbol, 

to the digital 

pump 
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A graphic descriptor of a blower appears in the diagram. 

3.  Double click the graphic to open the properties page for Animated Symbol . 

 

4.  In the Categories pane, scroll down to the category Pumps  and select one of the pumps in 

the second line of the Symbols in category pane. 

 

Select the Stretchable  checkbox and observe what happens to the graphic.  

Clear the Stretchable  checkbox again. 
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5.  Click the OK button and the graphic comes onto the diagram. 

6.  Position the pump graphic as shown below 

 

7.  We now need to create a digital object with no display. 

In the menu, click Objects > bŜǿ ¦ƴǊŜŦŜǊŜƴŎŜŘΧ to open Object Browser.  

8.  In the left pane, expand the Workshop / Digital folder and select the (None)  folder. 

9.  In the Create new object group 

¶ In the Name field, enter ”p4”  

¶ In the Description field, enter ”2-state.” 

10.  Click the Create  button to open the Object properties form for p4.  

Notice there is no Display  tab. 

11.  Click the Data Management  Definitions tab and 

¶ Select the 5000 option in the Scan interval  group 

¶ Select the None  option in the Logging  group 

¶ Select the 5 option in the Base interval  group 

¶ Select the Change  checkbox in the Data reduction  group 
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12.  Click the Edit Mapping  tab and  

¶ Select the Command  checkbox in the Atom group and then select “local” in the I/O 

mode  field. 

¶ Select the State  checkbox in the Atom group and then select “local” in the I/O mode  

field.  

13.  Click the OK button. 

14.  On the diagram, right-click on the pump graphic and select Connect . 

15.  In the Object Browser  find and select the pump p4 and click the Open/Select  button. 

The pump graphic is now connected to the object properties we defined for p4 and the new 

Animated Symbol  tab has been added to the properties tabs for the pump. 

16.  Click the Animated Symbol tab and in the upper right hand corner in the drop down box 

with the default setting In alarm , select the <-0 setting. This is the OFF state for p4 and the 

pump. 

¶ In the Fill Color Mode  field, select “Shadedò  

¶ In the Fill Color  field, select a blue color 

Return to the drop down box and select the <-1 setting, which is the ON state for q4 and the 

pump. 

¶ In the Fill Color Mode  field, select ñSolidò 

¶ In the Fill Color  field, select a dark green color 

¶ Clear the Transparent checkbox 

¶ In the Background Color  field, select a yellow color. 

17.  Click the Display  tab and 

¶ In the Name group, 

o select the Enable  checkbox 

¶ In the State / Value  group,  

o select the Enable  checkbox 

o In the Atom  field, select άCommandò 

18.  Click OK to finish and save. 
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The pump should now have a blue color, representing the OFF state. 

 

 

Our final task is to use the Calculation function to automatically control the 

pump, p4. Our aim is to ensure that p4 is stopped every time the flow through 

the gauge q1 is greater than a given speed. 

 

Step Action 

1.  Right-click on the p4 graphic and select the Properties option 

Click the Calculatio n tab. 

2.  In the Atom  group, select the Command  checkbox 

In the Execution trigger  group, select the On object changes in expression  

option. 

Task 5: 

Using Calculation 

on p4 
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3.  In the Command field, enter : “IIF(Value('q1')>28, 0,1) “ 

This expression will set the command to 0, stopping the pump (p4) if the value of 

q1 exceeds 28 m3/hr., otherwise the pump will continue to run (the command is 

set to 1. 

Note 
You must enter the expression exactly as it is written. There is a space between 

the comma and the zero. If not written exactly as shown, an error will result. 

4.  Click the ¢Ŝǎǘ 9ȄǇǊŜǎǎƛƻƴΧ button to verify that the syntax is correct. 

The Definition dialog box should display the text: 

Expression is OK. 

Expression result IIF(Value('q1')>28, 0,1) = 0.000000 

Click the OK button to close the Definition dialog 

5.  It is a good idea to provide a short description of what the expression is 

supposed to perform. 

In the Comment field, enter "The pump runs until the flow on q1 is greater than 

28, then it's automatically stopped."  

6.  Click the OK button. 

7.  Right-click on the flow gauge q1 and select the Properties option. 

Click the Calculation tab and select the Actual value checkbox in the Atom 

group. 

¶ In the Execution Trigger group, select the On timer option and enter 

“1000” in the Timer value (in mSecs.) field. 

¶ In the Actual Value field in the Expression group, enter 

“(Value('q1')+4) MOD 100ò  

¶ Select the Only execute expression if this condition is true checkbox and 

the field under the checkbox becomes available. 

¶ In the field under the Only execute expression if this condition is true 

checkbox, enter “MSecsSinceLastExec()>3000” 

¶ In the Comment field, enter: “The gauge is incremented with 4 every 3 

seconds until it reaches its maximum of 100. Then it falls to zero and is 

incremented by 4 again until it reaches 100”. 
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8.  Click the ¢Ŝǎǘ 9ȄǇǊŜǎǎƛƻƴΧ button to verify correct syntax. 

The Definition dialog box should display the text: 

Condition syntax is OK. 

Condition result: FALSE (-0.000000) 

---------------------------------------------------------------------------------- 

Expression is OK. 

Expression result IIF(Value('q1')>28, 0,1) = 66.000000 

Click the OK button to close the Definition dialog 

9.  Click the OK button to save the calculation settings for the pump (q4). 
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10.  In the toolbar, click the Save button. 

In the menu, click File > Check and Install to perform a check of the diagram and 

objects and to install the configuration. 

If there are any errors in the configuration, an error dialog will appear, allowing 

you to correct any errors. The configuration will not be installed if there are any 

errors, but you can still save the configuration and troubleshoot the errors later. 

11.  Click the OK button to close the Definition dialog to close the Definition window 

12.  In the IGSS Master, click Home tab > Start button to start the project. 

In the IGSS Master, click Home tab > Supervise button to open the mimic 

diagram. 

The pump is colored blue, indicating it has stopped. 

Right-click the p4 pump and select 1-> to start the pump. Notice the color 

change of the animated pump symbol to green. 

Right-click the p4 pump again and select 0-> to stop the pump. The color of the 

animated pump symbol changes back to blue. 

 

EXPLANATION: 

Atom: we choose the Actual Value atom to manipulate with our expression 

Execution trigger :  We choose to have the expression executed on the basis of 

time intervals, On timer, Timer value (in mSecs)in this case 3000 milliseconds 

Expression :  We want the 4 units to be added to the Actual Value of the flow 

gauge (Value('q1')+4), and when the maximum range of q1 is reached, which 

is100, then we want to start anew with the Actual Value being set to zero, MOD 

100. 

Only execute expression if this condition is true: We don’t want the addition of 4 

units to occur until at least 3000 milliseconds have elapsed since the last time 4 

units were added, MsecsSinceLastExec()>3000 

RESULT: the q1 flow gauge will register an increase in flow with increments of 4 

until it reaches 100 at which time it will go back to zero and begin anew. 
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Complete this optional task if you have time left after completing all the other 

tasks in this exercise. 

We wish to create a set of abbreviations for measurement units, which we will 

then be able to choose for any object in our project. These will appear on the tab 

where the name of the object can be changed, for instance on the Analog  tab for 

analog objects. 

You must create the following measurement abbreviations: 

¶ M3/hr.  to indicate the flow per hour through a gauge. 

¶ Hrs. to indicate the number of hours the mixer motor and the pump has 

been in operation. 

¶ m. to indicate the water level in the water tank. 

Create Unit Set  

All measurement abbreviations must belong to a unit set in IGSS and you must 

therefore first define the unit set which your measurement abbreviations are to 

belong to.  

Step Action 

1.  In the menu, Click Edit >  Unit Sets to  open the Unit Sets form where you can 

create and maintain customized definitions for units. 

2.  In the Unit Sets form, click the New button and enter the name “Plant1” for the 

new unit uet. 

3.  Click the Close button to save your unit set and exit the form. 

 

Create measurement abbreviations 

After you have created the unit set, you can create the measurement 

abbreviations you want to use in the unit set. 

1.  In the menu, Click 9Řƛǘ Ҕ  aŜŀǎǳǊŜƳŜƴǘ ¦ƴƛǘǎΧ to  open the Base Units form 

2.  In the Base Units form, click the New button to open the Edit Base Unit form. 

3.  In the Unit text field, enter “m3/hr” which is the abbreviation of the first 

measurement unit you need. 

In the Member of units set field, select “Plant1” in the drop down box. 

Click the OK button to close the Edit Base Unit form and return to the Base Units 

OPTIONAL TASK:  

Create a new 

Units set for use 

in defining 

objects 
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form. 

 

 

 

4.  In the Base Units form, click the New button to open the Edit Base Unit form. 

5.  In the Unit text field, enter “Hrs.” which is the abbreviation of the second 

measurement unit. 

In the Member of units set field, select “Plant1” in the drop down list. 

Click the OK button to close the Edit Base Unit form and return to the Base Units 

form. 

6.  In the Base Units form, click the New button to open the Edit Base Unit form. 

7.  In the Unit text field, enter “m.” which is the abbreviation of the final 

measurement unit. 

In the Member of units set field, select “Plant1” in the drop down box. 

Click the OK button to close the form and return to the Base Units form. 

 
Tip 
If you make a mistake, you can either delete the base unit entry or edit it in the 

Base Units form. 

Update the objects in the diagram with the measurement 

abbreviations 

After you have created the measurement abbreviations, you must go back to the 

objects in the Exercise  project and add the appropriate unit in the Units  field of 

the objects. 

There are three objects you must adjust: 

¶ Flow gauges q1 (Analog object), uses the M3/hr measure 

¶ Flow gauge q2(Analog object),  uses the M3/hr measure 

¶ The mixer motor counter C1 (Counter object) , uses the hrs. measure. 

The dialog box 

for creating new 

units 

Choose the newly 

created Plant1 from 

drop-down box. 

Type in the name of the 

unit desired 
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You can access the objects unit field in three methods: 

¶ Through the object in the mimic diagram  

¶ Through the Object Browser 

¶ Through the Property table view  

The following instructions cover all three of the methods of accessing an object. 

Through the object in the mimic diagram 

1.  In the mimic diagram, right-click the q1 object  and select Properties. 

2.  Click the Analog tab. In the Units field, select the “M3/hr” value from the drop-

down list in the field. 

3.  Click the OK button to close the form. 

Through the Object Browser 

1.  In the menu, click File > Object Browser to open the Object Browser form. 

2.  In the Object Browser form, expand the Workshop/ Analog folders in the left 

pane and select the Analog folder. 

3.  Select the q2 object in the list in the right pane and click the Open / Select button 

in the Open by name group. 

4.  The object q2 is displayed with an animated symbol in the mimic diagram. 

5.  In the mimic diagram, right-click the q2 object and select Properties. 

6.  Click the Analog tab. In the Units field, select the “M3/hr” value from the drop-

down list in the field. 

7.  Click the OK button to close the form. 

Through Property table view 

1.  Right-click in an empty area in the mimic diagram and select Property table viewΧ 

2.  In the Property table view form, expand the Training / Objects / Standard folders 

in the left pane and select the Counters folder. 

3.  In the right-pane, in the Unit column for the C1 @ Workshop counter, select the 

Hrs. value in the drop-down list. 

Tip 
You must double-click in the Units field to activate the drop-down list. 

4.  Close the Property table view form to return to the mimic diagram. 

 
 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE !! 
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Exercise 5: Create Templates and Template Based Objects 

 

¶ Learn how to create templates and create objects with a template. 

¶ Understand the benefits of using templates. 

 

30 - 45 minutes. 

 

We will create an analog template to be used later when we create level gauges. 

Templates are created in and contained in Areas. If you want to make your 

templates globally available, create the template in the Global  area. 

TIP 
When you name your template, use CAPITAL LETTERS so the template can be 

easily identified when determining object characteristics.  

 

Step Action 

1.  In the IGSS Master. Click Design and Setup tab > Definition button to open the 

Definition form. 

In the menu of the Definition form, click Area > Workshop. 

In the menu of the Definition form, click Diagram > Training.  

2.  In the menu of the Definition form, click Template > Create to open the Create 

Template form. 

3.  In the Create Template form: 

¶ In the Area field, select “Global” 

¶ In the Type group, select the Analog option 

¶ In the Name field, enter “LEVEL” 

¶ In the Description field, enter “level gauge” 

Click the OK button to open the LEVEL - level gauge form. 

Purpose 

Duration 

Task 1: Create an 

analog template 
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4.  In the LEVEL ς level gauge form, click the Analog tab 

¶ In the Max. field, enter: "10.00" 

¶ In the Min. field, enter: "0.00" 

¶ In the No. of decimals field, enter: "2" 

¶ In the Units field, select "m."  (see note) 

¶ Select the High Alarm check box and in the input field to the right of the 

High Alarm checkbox, enter: "9.00" 

¶ In the Actual Value field, enter:  "5.00" 

Note 
If you have not defined the measurement abbreviations  in the optional task for 

exercise 4, you can skip defining the Units field 

5.  In the LEVEL - level gauge  form, click the Edit Mapping  tab 

Set up High Alarm properties: 

1) In the Atom group, select the High Alarm checkbox  

2) In the I/O Mode field select “Local” for the high alarm.  

3) In the Alarm Details Group: 

a. Click the New button to open the Edit Alarm Description form. 

b. Verify the value in the Alarm no. field is “104”. 

c. In the Alarm text field, enter “High alarm exceeded!”  

d. In the Priority field, enter “10”  

e. In the Instructions field, enter “Take corrective action!” 

f. Click the OK button 

Set up Actual Value properties: 

1) In the Atom group, select the Actual Value checkbox  

2) In the I/O Mode field select “in” for the actual value. 

3) In the PLC Node for object: LEVEL  Group: 

a. Verify the Driver: field contains the PLC driver we chose in 

System Configuration (7TS7TCP (IGSS_Server)  
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b. Verify the Node: field value is “0”. 

c. In the Data Block Number field, enter: “21” 

d. In the Offset field, enter: “14” 

e. In the Bit Offset field, enter: “0” 

f. In the External type field, select “FP16S” 

6.  In the LEVEL - level gauge form, click the Data Management Definitions  tab 

¶ In the Scan interval group, select the 5000 option. 

¶ In the Logging group, select the > 2% option. 

¶ In the Base interval group, select the 30 option. 

¶ In the Data Reduction group, select the Average, Min. and Max. 

checkboxes 

¶ In the Transfer to History group, select the Reduced value option. 

7.  In the LEVEL - level gauge form, click the OK button to create the LEVEL analog 

object template. 

 

After having created the analog object template, we will to create a digital object 

template which we will be using to create a number of pumps later on. 

TIP 
When you create the digital object template, remember to create it in the Global  

area and name it with CAPITALS. 

Hint 
When you are defining the Command/State configuration in step 7 below, use the 

following table: 

When the state is 
actiǾŜΧ 

The following commands 
are accessible: 

Color of pump 
symbol 

¶ Off ¶ Slow Red 

¶ Slow ¶ Stop 

¶ Medium* 

Yellow 

¶ Medium ¶ Slow 

¶ Fast 

Green 

¶ Fast ¶ Medium Blue 

Explanation 
The table illustrates the following relationship: 

¶ When the pump is Off, the only available command is Slow.  

Task 2:  

Create a digital 

template  
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¶ When the state of the pump is Slow, the available commands are Stop 

and Medium, where Medium is the default value.  

¶ When the state of the pump is Medium, the available commands are Slow 

and Fast  

¶ Finally when the state of the pump is Fast, the only available command is 

Medium. 

The color of the pump symbol will reflect the pump states so if a pump is off, the 

symbol for that pump will red and if the pump is running fast, the symbol will be 

blue. 

 

Step Action 

1.  In the menu of the Definition form, click Template > Create to open the Create 

Template form. 

2.  In the Create Template form: 

¶ In the Area field, select “Global” 

¶ In the Type group, select the Digital option 

¶ In the Name field, enter “PUMP” 

¶ In the Description field, enter “4-state pump” 

Click the OK button to open the PUMP ς 4-state pump form. 

3.  In the PUMP ς 4-state pump form, click the Bit Map I/O tab. 

In the To PC State bit map, in the far right byte: 

¶ click once below the bit 0 to enable it as a state bit 

¶ click once below the bit 1 to enable it as a state bit 

In the From PC Command bit map, in the far right byte: 

¶ click once below the bit ά0ò to enable it as a command bit 

¶ click once below the bit “1ò to enable it as a command bit 

A dash "-" will be displayed in the byte when you click correctly.   

Note 
Do not click the lower row (the 1) in the byte.  

See the picture below 
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4.  In the PUMP ς 4-state pump form, click the Alarm In/Ack Bit tab. 

In the To PC bit map, in the far right byte: 

¶ Click once below bit 0 to activate it as an alarm indication bit to PC (a 

plus sign "+" appears). 

¶ Click once below bit 1 to activate it as an alarm indication bit (a plus sign 

"+" appears). 

¶ Click twice below bit 7 as alarm acknowledgement bit from the PLC to 

the PC (an asterisk "*" appears). 

In the From PC bit map, in the far right byte:  

¶ Click once below bit 7 to enable it as alarm acknowledgement bit from 

the PC (an asterisk "*" appears). 

In the Single Bits group, select the Alarms checkbox 

See the picture below. 
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5.  In the PUMP ς 4-state pump form, click the States and Commands tab. 

In the State group: 

¶ Select the <-0 state, in the input field, enter “Off” and click the Add State 

button. 

¶ Select the <-1 state, in the input field, enter “Slow” and click the Add 

State button. 

¶ Select the <-2 state, in the input field, enter “Medium” and click the Add 

State button. 

¶ Select the <-3 state , in the input field, enter “Fast” and click the Add 

State button. 

In the Command group: 
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¶ Select the <-0 command, in the input field, enter “Stop” and click the 

Add Command button. 

¶ Select the <-1 command, in the input field, enter “Slow” and click the 

Add Command button. 

¶ Select the <-2 command, in the input field, enter “Medium” and click the 

Add Command button. 

¶ Select the <-3 command, in the input field, enter “Fast” and click the Add 

Command button. 

Note 
The Add State and Add Command buttons are only accessible if a value has been 

entered in the input field in the State and/or Command groups. 

 

6.  In the PUMP ς 4-state pump form, click the Data Management Definitions tab. 

¶ In the Scan interval group, select the 5000 option. 

¶ In the Logging group, select the All changes option. 

¶ In the Base interval group, select the 10 option. 

¶ In the Data Reduction, group, select the Change checkbox. 

¶ In the Transfer to History group, select the Actual Total Value. 

7.  In the PUMP ς 4-state pump form, click the Command/State Config tab. 

¶ In the States group, select the Off state and in the Commands group, 
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select the Slow checkbox. 

¶ In the States group, select the Slow state and in the Commands group, 

select the Stop checkbox and select the Medium checkbox. 

¶ In the States group, select the Slow state and in the Default Command 

field, select Medium. 

¶ In the States group, select the Medium state and in the Commands 

group, select the Slow checkbox and select the Fast checkbox. 

¶ In the States group, select the Fast state and in the Commands group, 

select the Medium checkbox. 

See the Hint at the beginning of this exercise for an overview of the states and 

commands. 

8.  In the PUMP ς 4-state pump form, click the Edit Mapping tab. 

Set up the Command properties: 

1) In the Atom Group, select the Command checkbox 

2) In the I/O Mode field, select “out” 

3) In the PLC address for object PUMP group: 

a. In the Driver field, select “7TS7TCP (IGSS_Server)” 

b. In the Node field, select “0” 

c. In the Data Block number field, enter “22” 

d. In the Offset field, enter “10” 

e. In the Bit Offset field, enter “0” 

f. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the State properties: 

1) In the Atom Group, select the State checkbox 

2) In the I/O Mode field, select “in” 

3) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “23” 

b. In the Offset field, enter “10” 

c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the Alarm-In properties: 

1) In the Atom Group, select the Alarm-In checkbox 

2) In the I/O Mode field, select “in”  
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3) In the Alarm Details group 

a. In the Digital Alarms field, select “<+ 1.” 

b. Click the New button to open the Edit Alarm Description form. 

c. Verify the value in the Alarm no. field is “105”. 

d. In the Alarm text field, enter “Pump defective”  

e. In the Priority field enter “100”  

f. In the Instructions field, enter “Change pump” 

g. Click the OK button. 

h. In the Digital Alarms field, select “<+ 2.” 

i. In the alarm text input field above the Digital Alarms field, select 

“105 : Pump defective”. 

4) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “24” 

b. In the Offset field, enter “10” 

c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the Alarm-Out properties: 

1) In the Atom Group, select the Alarm-Out checkbox  

2) In the I/O Mode field, select “out” 

3) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “25” 

b. In the Offset field, enter “10” 

c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Note 
The same alarm number and text is used for the two alarms for Alarm in. You 

can, as an optional exercise, create a new alarm number and text for the second 

alarm in. 

9.  In the PUMP ς 4-state pump form, click the Symbol Definition tab. 

Use the  pump symbol to represent the pump in all its state. You must 

change the color-coding of the symbol though. 

In the Digital state for symbol group: 

¶ Select “Off” 

¶ In the Choose symbol group in the Symbol table field, select “Blowers, 

Compr, Pumps” and select the pump symbol depicted above. 

¶ In the Choose symbol color field in the Symbol properties group, select a 

red color for the symbol. 
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In the Digital state for symbol group: 

¶ Select “Slow”  

¶ In the Choose symbol group in the Symbol table field, select “Blowers, 

Compr, Pumps” and select the pump symbol depicted above. 

¶ In the Choose symbol color field I the Symbol properties group, select a 

yellow color for the symbol. 

In the Digital state for symbol group: 

¶ Select “Medium”  

¶ In the Choose symbol group in the Symbol table field, select “Blowers, 

Compr, Pumps” and select the pump symbol depicted above 

¶ In the Choose symbol color field I the Symbol properties group, select a 

green color for the symbol. 

In the Digital state for symbol group: 

¶ Select “Fast”  

¶ In the Choose symbol group in the Symbol table field, select “Blowers, 

Compr, Pumps” and select the pump symbol depicted above 

¶ In the Choose symbol color field I the Symbol properties group, select a 

blue color for the symbol. 

In the Template inheritance group: 

¶ Select the Copy symbols to template checkbox to make symbols and 

colors available to objects based on this template. 

10.  In the PUMP ς 4-state pump form, click the OK button to save the digital 

template. 

 

 

After having created the two templates, you need to augment the mimic diagram 

with some new symbols and pictures. 

You will create and place a pipe symbol and an image to represent the water tank 

in the mimic diagram. Finally, you will use the LEVEL analog template to create a 

new object (L1).  

The L1 analog template will be used to monitor the level of the water in the water 

tank and will resemble a bar-meter. 

Task 3:  

Create a new 

object based on 

the template 

LEVEL 
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Step Action 

1.  In the menu of the Definition form, click View > Drawing toolbar to display the 

Drawing toolbar in the Definition form. 

Yu can skip this step if the Drawing toolbar is already displayed in the Definition 

form. 

2.  Create and position the pipe in the mimic diagram. 

¶ In the Drawing toolbar, click the Animated Symbol  ( ) and drag it 

into the mimic diagram. A symbol of a blower appears. This is the default 

symbol and must be changed. 

¶ Right-click on the blower symbol and select Properties to open the 

Descriptor properties form. 

¶ In the Descriptor properties form in the Categories group, click the Pipes 

category. 

¶ Select a symbol for the pipe in the Symbols in category group. 

¶ Select the Stretchable checkbox. 

¶ Click the OK button top close the Descriptor properties form  

¶ Resize and position the pipe you selected according to the diagram 

above. 

Place  the 

water tank 

image here  

Place the   L1 

bar display 

inside the 

tank. 

Place the 

pipe here  
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3.  Create and position the water tank image. 

¶ In the Drawing Toolbar, click the image icon and drag it into the 

mimic diagram. 

¶ The Open an image form is opened. 

¶ Navigate to C:\  IGSS \ Training Project and select the TANK-36.emf  

image file. The image is also found in the C:\ Program Data \7T \ IGSS32 

\ v9.0 \ GSSDemo \ Images  folder as well as on the USB stick. 

¶ Click the Open  button to import the image file into the mimic diagram. 

¶ Resize and position the water tank image according to the diagram 

above. 

4.  Create and position the L1 analog water level meter. 

In the menu in the Definition form, click Objects > Bar Display to open the 

Object Browser form. 

In the left pane of the Object Browser form, expand the Workshop / Analog 

folder and click the LEVEL folder. 

In the Create new object group: 

¶ In the Name field, enter “L1”  

¶ In the Description field, enter “Water level in tank”  

Click the Create button to open the L1 - Water level in tank form. 

5.  In the L1 - Water level in tank form, click the Edit Mapping tab 

¶ In the Atom group 

o Select the Actual Value atom 

¶ In the PLC Node for object: L1 group 

o In the Offset field, enter “10” 

6.  In the L1 - Water level in tank form, click the Attributes of the Bar tab 

¶ In the Show Limits group located in the middle of the form) 

o Select the No Limits option 

¶ In the Bar view group (located in the top right of the form) 

o Select the 2-D view option 
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7.  In the L1 - Water level in tank form, click the OK button to create the L1 object. 

8.  Position and resize the L1 bar display object to fit within the tank opening. 

 

After having created the analog object, symbols and images, you can now create 

three new pumps (p1, p2, p3 ) based on the PUMP template and place the pumps 

according to the diagram displayed below. 

 

Step Action 

1.  In the Definition form, click Objects > Blowers, Compr and Pumps to open the 

Object Browser  form. 

2.  In the left pane of the Object Browser  form , expand the Workshop / Digital 

folder and click the PUMP folder. 

In the Create new object group: 

¶ In the Name field, enter άp1έ 

¶ In the Description field, enter “Pump” 

Click the Create button to open the p1 - Pump form. 

Task 4: 

Create three 

objects based on 

PUMP template 

Place p1 here 

Place p2 here 

Place p3 here 
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3.  In the p1 - Pump form, click the Edit Mapping  tab.  

Go to the and give the pump a unique PLC address by simply adding a new Word 

Offset . 

Set up the Command properties: 
1) In the Atom Group, select the Command checkbox 

2) In the PLC address for object PUMP group: 

3) In the Offset field, enter “11” 

Set up the State properties: 
1) In the Atom Group, select the State checkbox 

2) In the PLC address for Command atom group: 

3) In the Offset field, enter “11” 

Set up the Alarm-In properties: 
1) In the Atom Group, select the Alarm-In checkbox 

2) In the PLC address for Command atom group: 

3) In the Offset field, enter “11” 

Set up the Alarm-Out properties: 
1) In the Atom Group, select the Alarm-Out checkbox  

2) In the PLC address for Command atom group: 

3) In the Offset field, enter “11” 

4.  In the p1 - Pump form, click the Symbol Definition  tab  

¶ In the Template inheritance  group, click the Copy Symbols  From 

Template  button. The template’s symbols and colors will be replicated 

to the p1 object. 

¶ Click the Off, Slow, Medium and Fast states in the Digital state for 

symbol group to verify that the symbols and colors have been replicated 

correctly. 

5.  Click the OK button to create the p1 digital object 

Place the p1 object in the mimic diagram as shown in the image above. 

6.  Repeat steps 1 to 6 for the p2 and p3 digital objects. 

In step 3, set the value in the offset field as follows: 

¶ p2 Offset field value: 12 

¶ p3 Offset field value: 13 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE 
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Exercise 6: Create and Show Events 

 

In this exercise you will create different types of events. The event types can be 

divided into three main categories: 

¶ System events 

¶ Periodical events 

¶ User defined events 

The events will be shown in the Event List which is shown just below the Alarm 

List . The list is fully user defined, so you decide yourself which events to show. 

The events can be defined both from the Definition and Supervise forms. 

 

In this task we will define an event to occur every time the project is started or 

stopped. 

Step Action 

1.  In the Definition form, click Edit > Event List to open the Events form 

2.  In the Events form, click the Add button to open the Edit Event form 

3.  In the Edit Event Form 

In the Event group 

¶ In the Name field, enter “Start/Stop of project” 

¶ In the Type field, select “System Start/Stop” 

¶ Select the To History checkbox to save the event in the event log. 

Purpose 

Task 1: Create a 

system event 
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4.  Click the OK button to add the event type to the Events form. 

 

In this task we will create a monthly event which tells the operator to email a 

report to the municipal authorities. 

Step Action 

1.  In the Definition form, click Edit > Event List to open the Events form 

2.  In the Events form, click the Add button to open the Edit Event form 

3.  In the Edit Event Form 

In the Event group 

¶ In the Name field, enter “E-mail report to municipal authorities” 

¶ In the Type field, select “Periodical” 

¶ Select the Alarm on event checkbox to display the event in the Alarm 

List. 

¶ Select the To History checkbox 

¶ In the Period field, select”1” and “Month” 

Task 2: Create a 

periodical event 
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¶ In the First event at field, enter yesterday’s date. 

 

4.  Click the OK button to add the event type to the Events form. 

 

One of the two pumps must be running all the time to supply the tank with water. 

Therefore, we want an event (and an alarm) if both pumps are stopped at the 

same time. 

Step Action 

1.  In the Definition form, click Edit > Event List to open the Events form 

2.  In the Events form, click the Add button to open the Edit Event form 

3.  In the Edit Event Form 

In the Event group 

¶ In the Name field, enter “p1 and p2 stopped” 

¶ In the Type field, select “User defined” 

¶ Select the Alarm on event checkbox 

¶  Select the To History checkbox 

In the Criteria group, create the first criteria 

Task 3: Create a 

user defined 

event 
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¶ Click the Add Criteria  button to create a new criteria 

¶ Click the Object Browser button to open the Object Browser  form. 

¶ Find the p1 pump (see Exercise 1 Online in Runtime mode above for 

instructions how to find objects with the Object Browser form. 

¶ Drag the p1 object from the Object Browser  form into the 

Object/template  field in the Edit Event  form. 

¶ In the Atom  column, select ñStateò 

¶ In the Relation  column, select ñ=(Value)ò 

¶ In the Object column, enter “0” (which means the pump has stopped) 

In the Edit Event  form, click the Add Criteria  button to create the second 

criteria. 

¶ In the Type field, select òANDò 

¶ Click the Object Browser button to open the Object Browser  form. 

¶ Find the p2 pump. 

¶ Drag the p2 object from the Object Browser  form into the 

Object/template  field of the newly created criteria in the Edit Event  

form. 

¶ In the Atom  column, select ñStateò 

¶ In the Relation  column, select ñ=(Value)ò 

¶ In the Object column, enter “0” (which means the pump has stopped) 
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4.  Click the OK button to add the event type to the Events form.  

 

 

We will now start the project and stop both pumps to trigger the user defined 

event. 

Step Action 

1.  In the Definition form, click File > Check and Update if the project is running or  

click File > Check and Install if the project is stopped. 

2.  (If the project is not started)  

In the IGSS Master, click Home tab > Start to start the project. 

3.  In the IGSS Master, click Home tab > Supervise to open the Supervise form. 

4.  Open the Active Alarms form (the Alarm List)  

Task 4: Test the 

events 
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(See Exercise 1 Alarm Handling for instructions on how to open the Active 

Alarms form) 

5.  In the lower left pane in n the Active Alarms form, click the Event log folder 

Notice that the “Start/stop of configuration” event is displayed in the Event 

List .  

 

6.  Stop both the pumps  p1 and p2. 

¶ In the Supervise form, find the p1 object, right-click and select the 

“Stop” option. 

¶ In the Supervise form, find the p2 object, right-click and select the 

“Stop” option. 

7.  Open the Active Alarms form (the Alarm List)  

Verify that the “p1 and p2 stopped” event is displayed in the Event List and the 

alarm number 90 (alarm generated by event) appears in the Alarm List  pane 

above. 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE  !! 
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Exercise 7: Create a Time Plot 

 

This exercise demonstrates how you can use the new graph type to create 

traditional time plots and display them in an embedded graph in a new diagram. 

15 - 20 min. 

In this first task we will embed a graph in the Training mimic diagram displaying 

the process values from the two analog object flow gauges, q1 and q2. 

 

Step Action 

1.  In the Definition form, click Diagram > Create to open the New Diagram 

Properties form. 

the New Diagram Properties form: 

In the Name field, enter “Graphs” 

In the Description field, enter ”Graph Training Diagram” 

In the Window Properties group, select the Name to Menu checkbox 

In the Background group, select the Color option and click the Browse button to 

open the Color form. 

In the Color form, select a new background color and click the OK button 

In the New Diagram Properties form, click the OK button to create the new 

diagram. 

The Graphs diagram is opened. 

2.  If the Drawing toolbar is not displayed in the Definition form, in the menu, click 

View > Drawing toolbar . 

3.  In the Drawing toolbar, click the Embedded graph button ( )  

Click in the middle of the Graph diagram, an empty graph is inserted in the 

diagram. 

4.  Right-click (or double-click) inside the empty graph to open the Graph 

Properties  form.  

5.   In the Objects tab, in the Graph Properties  form, click the Add button to open 

the Graph Object Parameters form and add the first object to the graph. 

Purpose 

Duration 

Task 1: Create a 

time plot 
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6.  In the Graph Object Parameters  form, click the Browse button to open the 

Object Browser form. 

7.  In the Object Browser form, find the q1 analog object  

Select the q1 analog object and click the Open / Select  button. 

The q1 analog object is transferred to the Graph Object Parameters form. 

8.  In the Graph Object Parameters form 

In the Line Parameters  group: 

¶ In the Color dropdown box, select a brown color 

In the Point Parameters  group:  

¶ In the Size field, enter  “5” 

¶ In the Style field, select “Dot” 

Select the Show Legend checkbox  

 

In the Graph Object Parameters form , click the OK button. 

9.  Repeat steps 5 – 8 for the q2 analog object and in step 8, select a different line 

color and point style for the q2 analog object 
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10.  Graph Object Parameters form, click the General  tab. 

In the Graph Title  group, in the Title field, enter άFlow Gaugesέ  

Click the OK button to generate the graph for the two analog objects.  

The new graph appears showing random values for the included objects. 

 

11.  In the menu, click File > Check and Install to install the project. 

12.  In the IGSS Master, click the Home tab > Start button to start the project. 

13.  In the IGSS Master, click the Home tab > Supervise button to open the Supervise 

form. 

In the menu, click Area > Workshop 

In the menu, click Diagram > Graphs  diagram  

Verify that the graph in the diagram displays the values for the q1 and q2 analog 

objects you expect the graph  to display. 
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14.  Place the red marker above the incoming process values and notice that you can 

see the values in a small tooltip. 

 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE !! 
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Exercise 8: Create a Report Format and Generate a 

Periodical Report 

 

¶ Learn how to create report formats for printed reports. 

¶ Learn how to generate reports. 

 

20 - 30 minutes. 

 

We will create a new report format for our printed reports and name the 

headings we want in the report. The report format will be called Packaging  and 

the report format will cover all IGSS objects related to the packaging process and 

be used for generating a daily report. 

The report will have three headings: Flow, Level and Pump and contain data from 

the following process components (objects):  

¶ q1: Analog object - Flow meter 1 

¶ q2: Analog object - Flow meter 2 

¶ L1: Analog object  - Water tank 

¶ p1: Digital Object - Pump 1 

¶ p2: Digital Object - Pump 2 

¶ p3: Digital Object - Pump 3 

 

Step Action 

1.  In the Definition Form, click Edit  > Report Formats  to open the Report Formats  

form. 

2.  In the Report format  Group, click the Create button to open the Report Format 

Properties form. 

Purpose 

Duration 

Task 1: Create a 

new report 

format and 

report headings 
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3.  In the Report Format Properties form  

¶ in the Format name field, enter “Packaging” 

¶ Select the Set as default checkbox. 

¶ In the Report type group, select the Periodical report option. 

 

4.  Click the OK button to create the report format and return to the Report 

Formats form. 

5.  You now have to create the three headings you are going to use in the report. 

In the Report Formats form:  

Create the Flow report heading  

1) In the left pane, select the Packaging report format. 

2) In the Report Heading group, click the Create button to open the Report 

Heading Properties form. 

3) In the Report Heading Properties form, in the Heading Text field, enter 

“Flow”  

4) Click the OK button to return to the Report Formats form. 

Create the Level report heading  

1) In the left pane, select the Packaging report format. 

2) In the Report Heading group, click the Create button to open the Report 

Heading Properties form. 

3) In the Report Heading Properties form, in the Heading Text field, enter 

“Level”  

4) Click the OK button to return to the Report Formats form. 

Create the Pumps report heading  

1) In the left pane, select the Packaging report format. 
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2) In the Report Heading group, click the Create button to open the Report 

Heading Properties form. 

3) In the Report Heading Properties form, in the Heading Text field, enter 

“Pumps”  

4) Click the OK button to return to the Report Formats form. 

 

6.  You now have to include some of the objects under the report headings you just 

created. 

Add q1 and q2 analog objects to the Flow report heading 

1) In the left pane of the Report Formats form, click the Flow report 

heading. 

2) In the Chosen Objects group, click the Browse button to open the Object 

Browser form. 

3) In the Object Browser form, find and select the q1 analog object 

4) Drag the q1 analog object into the right pane of the Report Formats 

form. 

5) In the Object Browser form, find and select the q2 analog object 

6) Drag the q2 analog object into the right pane of the Report Formats 

form. 

Add L1 analog object to the Level report heading 

1) In the left pane of the Report Formats form, click the Level report 
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heading. 

2) In the Chosen Objects group, click the Browse button to open the Object 

Browser form. 

3) In the Object Browser form in the List Filter settings, select the Show 

reductions checkbox. 

4) In the Object Browser form, find and select the L1 analog objects for 

Average, Minimum and Maximum data reduction. 

5) Drag the L1 analog objects into the right pane of the Report Formats 

form. 

 

 

Add the p1, p2 and p3 digital objects to the Pumps report heading 

1) In the left pane of the Report Formats form, click the Flow report 

heading. 

2) In the Chosen Objects group, click the Browse button to open the Object 

Browser form. 

3) In the Object Browser form, find and select all the p1, p2 and p3 digital 

objects.  

Hint: Use “p*” in the Wild card text Criteria field) 

4) In the Object Browser form, select the p1, p2 and p3 digital objects and 

drag them into the right pane of the Report Formats form. 

5) In the Object Browser form, click the Close button to close the Object 

Browser form and return to the Report Formats form. 
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Note 
Since you are defining a periodical report, only objects with assigned data 

reductions can be used. This is why the Show reductions checkbox was selected 

above. You can include one or more data reductions for L1 (Average, Minimum 

and/or Maximum). 

7.  In the Report Formats form, click the OK button to close the form. 

8.  In the Definition form, in the toolbar, click the Save button to save your report 

format. 

In the Definition form, click File > Check and Install to. 

 

You can now create a daily report based on the format we just created. 

To do this, you must exit the Definition form and use the IGSS Master to create 

the report. 

 

Step Action 

1.  Go to the IGSS Master module. 

If the project is not started, you must start the project as the report will not be 

accessible if the project is stopped.  

To start the project: In the IGSS Master, Click Home tab > Start button 

Note 
You can also select the Start Basic Service Only option in the drop-down in the 

Start button. Reports and Dashboards can be executed even if the project is only 

running with basic services. 

2.  In the IGS S Master Wunderbar, double-click the Packaging report to start the 

Generate Standard Report form. 

3.  On the Generate tab, in the Report Date field, select today as the start date. 

4.  In the Output group, select the preview checkbox. 

5.  Click the Generate button to display a print preview of the report. 

6.  In the Generate Standard Report form, click the Close button to close the form. 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE !! 

Task 2: 

Generate a 

periodical report 
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Exercise 9: Use Standard Descriptors and the Library 

Toolbar 

 

¶ Learn how to use standard descriptors. 

¶ Learn how to connect standard descriptors to IGSS objects. 

¶ Learn how to use the Library toolbar.  

 

20 - 30 minutes. 

 

The Library toolbar is displayed in the diagram and the image of the tank is added 

to the Library toolbar for later use. 

 

Step Action 

1.  In the Definition form, click View  > Library toolbar display the Library toolbar  in 

the mimic diagram.  

2.  In the mimic diagram, click the tank image and drag it into the Library toolbar. 

3.  In the Library toolbar, right-click on the image and select Edit Tool Name  

In the Edit Tool name  dialog box, in the Tool name  field, enter òTank2ò. 

4.  Click the OK button. 

5.  In the Definition form, click View  > Library toolbar to remove the Library 

toolbar  from in the mimic diagram. 

 

A new level gauge (L2) is to be created and the L2 level gauge is to be based on 

the LEVEL  template and connected a polygon. A polygon is one of the standard 

descriptors which you will create in the exercise.  

The polygon will be set up reflect the current value of the water level in the tank. 

Purpose 

Duration 

Task 1: 

Add an image to 

the Library 

toolbar 

Task 2: 

Connect an 

analog object to 

a polygon 
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Step Action 

1.  In the Definition form, click Objects  > Standard Descriptors  > Polygon  to open 

the Object Browser  form.  

2.  In the left pane of the Object Browser  form, expand the Workshop  > Analog  > 

Template  folder and select LEVEL . 

3.  In the Object Browser  form in the Create New Object  group in the Name field, 

enter “L2”  

Position L2 here 
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4.  Click the Create  button.  

5.  In the L2 form, click the Edit Mapping  tab  

In the Atom group, select the Actual Value  checkbox.  

In the PLC Address for Actual Value atom  group  

In the Bit Offset field, enter “2”.  
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6.  Click the OK button to display the polygon descriptor in the mimic diagram as a 

triangle. 

7.  In the Definition form, click Format  menu > Snap to Grid  to facilitate 

positioning of graphics on the diagram. 

8.  Drag the polygon“ triangle into the cutout for L2.  

Hover the mouse over one of the vertices (the white squares in the polygon). 

When the mouse cursor changes to display a cross-hairs icon, double-click on 

one of the vertexes to add a new vertex.   

Add another handle to create five handles altogether.  

Move the five handles so that they fill out the entire cutout. 

 

In the Definition form, click Format  menu > Snap to Grid  to remove the grid 

from the diagram display. 
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9.  Right-click on the L2 polygon to open the L2 object properties form click the 

Attributes of Polygo n tab  

Edit background color 

1) In the left pane, expand the Bindings to Object folder and select 

Background Color. 

a. In the right pane, double-click the Bind Background color field in 

the Value column to toggle to a “Yes” value. 

b. Double-click the Above Alarm field in the Value column and 

select an orange color. 

c. Double-click the Not in Alarm field in the Value column and 

select the white color. 

 

 Edit object alarm bindings 

1) In the left pane on the Attributes of Polygo n tab, expand the click 

Bindings to object Alarms. 

a. In the right pane, double-click the Flash Background On Color 

field in the Value column and select an orange color. 

b. In the right pane, double-click the Flash Background Off Color 

field in the Value column and select an orange color. 

c. Double-click the Flashing Background field in the Value column 

and toggle to the “Yes” option. 
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Edit miscellaneous properties  

1) In the left pane on the Attributes of Polygo n tab, click Miscellaneous. 

a. In the right pane, double-click the ActiveFill Color field in the 

Value column and select a blue color to represent the tank filling 

up. 

 

 

10.  Click the OK button to save the changes and close the L2 form. 
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You will add a new graphic (Prop -1.gif ) from your machine to the Library 

Toolbar  and then drag it onto the diagram. 

 

 

Step Action 

1.  In the Definition form, click View  > Library Toolbar  

to display the Library toolbar in the diagram 

2.  Right-click in the Library toolbar and select Add new Tool. 

3.  On the local machine, navigate to the Training Project folder and find the Prop-

1.gif file 

4.  Click the Open button top add the selected Prop-1.gif to the Library toolbar in 

IGSS. 

5.  In the Library toolbar, right-click the newly added image and select Edit Tool 

name. 

6.  In the Edit Tool Name dialog, in the Tool Name field, enter “Prop-1ò and click the 

OK button. 

7.  From the Library toolbar, drag the Prop -1 into the mimic diagram and place the 

image as indicated shown in the figure above. 

 

Task 3: 

 Use the  

Library toolbar 

Position 

Prop_1.gif here 
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You will create a motor object called M1 and represent the process component 

on the mimic diagram with a gif file instead of using a standard symbol.  

The motor object is to be created based a new template called MOTOR, which we 

first have to create. 

 

Step Action 

1.  In the Definition form, click Template > Create to open the Create Template 

form. 

2.  In the Type group on the Create Template form, select the Digital option. 

In the Name field, enter “MOTOR” 

In the Description field, enter ”Motor Digital Object Template” 

Click the OK button to open the MOTOR ς Motor Digital Object Template form. 

3.  In the MOTOR ς Motor Digital Object Template form, click the Bit Map I/O tab 

In the To PC State bit map, in the far right byte: 

¶ click once below the bit 0 to enable it as a state bit 

In the From PC Command bit map, in the far right byte: 

¶ click once below the bit “0” to enable it as a command bit 

A dash "-" will be displayed in the byte when you click correctly.   

Note 
Do not click the lower row (the 1) in the byte. 

See the picture below 

Task 4:  

Create a digital 

template for a 2 

state motor 
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4.  In the MOTOR ς Motor Digital Object Template form, click the Alarm In/Ack Bit 

tab. 

In the To PC bit map, in the far right byte: 

¶ Click once below bit 0 to activate it as an alarm indication bit to PC (a 

plus sign "+" appears). 

¶ Click twice below bit 1 to activate it as an alarm acknowledgement bit 

(an asterisk "*" appears). 

In the From PC bit map, in the far right byte:  

¶ Click once below bit 0 to enable it as alarm acknowledgement bit from 

the PC (an asterisk "*" appears). 

See the picture below. 
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5.  In the MOTOR ς Motor Digital Object Template form, click the States and 

Commands tab. 

In the State group: 

¶ Select the <-0 state, in the input field, enter “Off” and click the Add State 

button. 

¶ Select the <-1 state, in the input field, enter “On” and click the Add State 

button. 

In the Command group: 

¶ Select the <-0 command, in the input field, enter “Stop” and click the 

Add Command button. 

¶ Select the <-1 command, in the input field, enter “Start” and click the 
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Add Command button. 

Note 
The Add State and Add Command buttons are only accessible if a value has been 

entered in the input field in the State and/or Command groups. 

6.  In the MOTOR ς Motor Digital Object Template form, click the States and 

Commands tab. 

In the States group, select the Off state and in the Commands group, select the 

Start checkbox. 

In the States group, select the On state and in the Commands group, select the 

Stop checkbox. 

7.  In the MOTOR ς Motor Digital Object Template form, click the Data 

Management Definitions  tab 

¶ In the Scan interval group, select the 5000 option. 

¶ In the Logging group, select the All changes option. 

¶ In the Base interval group, select the 10 option. 

¶ In the Data reduction group, select the Change option. 

¶ In the Transfer to History group, select the Actual Total Value option. 

8.  In the MOTOR ς Motor Digital Object Template form, click the Edit Mapping tab 

Set up the Command properties: 

1) In the Atom Group, select the Command checkbox 

2) In the I/O Mode field, select “out” 

3) In the PLC address for object PUMP group: 

a. In the Driver field, select “7TS7TCP (IGSS_Server)” 

b. In the Node field, select “0” 

c. In the Data Block number field, enter “25” 

d. In the Offset field, enter “10” 

e. In the Bit Offset field, enter “0” 

f. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the State properties: 

1) In the Atom Group, select the State checkbox 

2) In the I/O Mode field, select “in” 

3) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “26” 
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b. In the Offset field, enter “10” 

c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the Alarm-In properties: 

1) In the Atom Group, select the Alarm-In checkbox 

2) In the I/O Mode field, select “in”  

3) In the Alarm Details group 

a. In the Digital Alarms field, select “<+ 1.” 

b. Click the New button to open the Edit Alarm Description form. 

c. Verify the value in the Alarm no. field is “106”. 

d. In the Alarm text field, enter “Motor defective”  

e. In the Priority field enter “6”  

f. In the Instructions field, enter “Call maintenance team” 

g. Click the OK button. 

4) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “27” 

b. In the Offset field, enter “10” 

c. In the Bit Offset field, enter “0” 

d. In the External Type field, select “FP16S” from the dropdown 

menu. 

Set up the Alarm-Out properties: 

1) In the Atom Group, select the Alarm-Out checkbox  

2) In the I/O Mode field, select “out” 

3) In the PLC address for Command atom group: 

a. In the Data Block number field, enter “28” 

b. In the Offset field, enter “10” 

c. In the Bit Offset field, enter “0” 

In the External Type field, select “FP16S” from the dropdown menu. 

9.  In the MOTOR ς Motor Digital Object Template form, click the OK button to 

create the MOTOR digital template. 

 

After you have created the MOTOR digital object template, you can create the 

motor object called M1 based on the MOTOR template. Since you already have a 

symbol you want to connect the M1 digital object to (the Pump-1.gif symbol you 

created above) and don't want to use a standard symbol from the IGSS standard 

symbol library to represent the motor, create the  M1 digital object without 

symbol representation. 

Task 5: Create 

the motor object 

and connect to a 

gif file 
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Step Action 

1.  In the Definition form, click Objects > New Unreferenced to open the Object 

Browser form. 

Create the M1 object by first selecting from the Objects  menu the entry called 

New Unreferenced , which is found vertically down in the menu structure. 

2.  In the Object Browser  form, in the left pane, expand the Workshop > Digital 

folder and select the MOTOR template. 

3.  In the Create New object group, in the Name field, enter “M1” 

In the Description field, enter “Motor” 

4.  Click the Create  button to open the M1 ς Motor  form. 

5.  In the M1 ς Motor  form , click the Edit Mapping tab 

In the Atom group, select the Command  checkbox. 

¶ In the PLC Addresses  group, in the Bit Offset  field, enter ñ10ò. 

6.  Click the OK button to create the M1 digital object and position the object in the 
mimic diagram. 
 
Note 
There is no graphical representation on the mimic diagram for the M1 digital 

object yet.  

If you open the Object Browser form (In the Definition form, click File > Object 

Browser) you can see that the M1 digital object is present in the left pane of the 

Object Browser form under Workshop / Digital / Motor . 

The M1 digital object is not listed in the Property Table Viewer form, found by 

right-clicking the mimic diagram and selecting Property Table View form.  

In the left pane of the Property Table View form, expand the Objects / Standard 

/ Digitals folder. The M1 digital object is not listed. 

 

After you have created the M1 digital object based on the MOTOR digital object 

template, you can connect the Prop_1.gif  to the M1 digital object and give it a 

graphical representation on the mimic. 

Step Action 

Task 6: Connect 

the gif graphic to 

the M1 object. 
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1.  In the mimic diagram, right-click on the motor image (Prop-1.gif) and select the 

Connect option to open the Object Browser form. 

2.  In the Object Browser  form, find the object M1 digital object. 

Select the M1 digital object in the object list in the right pane of the Object 

Browser  form. 

3.  In the Open by name  group: 

¶ select the Go to diagram  check box 

¶ select the Show properties  checkbox 

Click the Open / Select  button to open the M1 ï Motor form. 

4.  In the  M1 ï Motor form, click the Attributes of GIF  tab. 

5.  In the left pane of the Attributes of GIF  tab, expand the Properties  / Bindings to 

Object State  folder. 

Select the Play  folder 

6.  In the right pane of the Attributes of GIF  tab  

¶ In the Bind Play  field, double-click the value column to toggle the field 

value to ñYesò 

¶ In the On field, double-click the value column to toggle the field value to 

ñYesò 

7.  In the left pane of the Attributes of GIF  tab, select the Miscellaneous  folder  

8.  In the right pane of the Attributes of GIF  tab  

In the Play Non Stop  field, double-click the value column to toggle the field value 

to ñYesò 

9.  In the M1 ï Motor form, click the OK button to save the M1 digital object settings 

and exit. The M1 digital object is now displayed in the mimic diagram. 

Note 
Open the Property Table Viewer and find the M1 digital object. It is now listed in 

the right pane. 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE !! 



IGSS Configuration Workshop Exercises  

 

 

 Page 88 of 113 

Exercise 10: Work with the Group Object 

Create a Family of Linked Group Objects  

Learn how to create a family of linked group objects and how to update the group 

objects simultaneously and dynamically. 

20 – 30 minutes 

For this exercise, we will switch to the IGSS Demo project and use the pump 

station. 

First you must save your work in your present Exercise project and stop the 

project. Then you have to find and start the Demo project which is included in the 

IGSS installation on your computer. 

Step Action 

1.  In the Definition form, click File > Save to save your work on the current project. 

Close the Definition form (Click File > Exit) 

2.  In the IGSS Master, click Home tab > Stop button to stop the training project. 

3.  In the IGSS Master, click Design and Setup tab > Open Project button and select 

the demo.elm file located in the C:\  IGSS \  Demo_V9  folder 

4.  In the Application menu, select Design mode 

5.  In the IGSS Master, click Design and Setup tab > Definition button to open the 

Definition form. 

 

The pump station in the demo project is a one-of-a kind pump station, but now 

we need to monitor two identical pump stations. Instead of creating two new 

mimic diagrams with new but identical objects, alarms and descriptors, we can 

use the linked group object to create a single diagram which can be reused to 

represent the all the objects common to all three pump stations. 

Once you have opened the Demo project, you are ready to start creating and 

using a group object. First you have to create the group object based on the 

objects in the pump diagram. Then you export the group object and import it 

again in to the same diagram. You have to change the settings of the diagram to 

enable the diagram to be reusable. You must rename the objects in order to avoid 

name collisions  

 

Purpose 

Duration 

Task 1: Close 

your project and 

open the Demo 

project 

Task 2: Create three 

linked Groups and 

show them on the 

same diagram 
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Step Action 

1.  In Definition form, double-click the IGSS Training button to open the Training 

Area. 

2.  In the Training Area, double-click the More Diagrams button. 

Double-click the Water Supply image to open the Water Supply diagram. 

Note 
Another way to access the Water Supply diagram could be to click Area > 

Training and then click Diagram > Water Supply in the menu in the Definition 

form. 

3.  In the Water Supply diagram, press CTRL + A to select all objects on the diagram. 

4.  In the Water Supply diagram, click Edit > Group Manager  to open the Group 

Manager form. 

In the Group Manager form, click the New Group button to open the Enter 

Name of Group dialog. 

In the Group name field, enter ”PST01-GRP” 

Click the OK button.  

5.  In the Group Manager form, click the Members tab > Add Selected Objects 

button to add all the objects you selected in step 3. 

6.  In the Group Manager form, click the Paste Options tab 

In the Modify name  group 

¶ select the Enable check box. 

¶ In the Naming convention field, enter “PST##- *ò 

¶ Select the Exclude templates from substitution check box 

In the Modify address mapping  group  

¶ Select the Node check box 

7.  In the Group Manager form, click the Export button to open the Export Group 

dialog box. 

In the File Name field, enter “PST01- GRP.cgf ” 

Click the Save button to save the group object export and close the Export Group 

dialog 



IGSS Configuration Workshop Exercises  

 

 

 Page 90 of 113 

Note 
The .cgf file which contains the exports of the group object will be placed in the 

same folder as the project by default but you can place the .cgf file wherever you 

want. 

8.  In the Group Manager form, click the Close button 

9.  In the Water Supply diagram, click File  > Import  

Select the PST01_GRP.cgf  file to import and click the Open  button to open the 

Paste Special  form. 

10.  In the Paste Special form : 

In the Paste referenced objects as group 

¶ Select the New objects  option to create a new set of objects. 

¶ Clear the Paste to new diagram checkbox. 

¶ Select the Automatically rename conflicting object names checkbox. 

¶ Clear the Paste report formats check box. 

¶ Clear the Paste event definitions checkbox. 

¶ Clear the Paste Objects only (no descriptors) checkbox. 

Click the OK button to open the Modify Options of Group Members  form 

11.  In the Modify Options of Group Members  form 

In the Name Substitution group 

¶ In the Substitutes field, enter “02” 

In the Address substitution group 

¶ In the Node field, enter “2ò to assign node no. 2 to all objects in the group. 

12.  Click the OK button to import the objects in to the Water Supply diagram. 

Note 
If you are prevented from importing the objects because of the 1,000 object 

restriction on the demo license, you can delete all objects in the District Heating 

diagram and the Pump Station diagram in order to remove some objects. 
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13.  In the Water Supply diagram, click File  > Import  

Select the PST01_GRP.cgf  file to import and click the Open  button to open the 

Paste Special  form. 

14.  In the Paste Special form : 

In the Paste referenced objects as group 

¶ Select the New objects  option to create a new set of objects. 

¶ Clear the Paste to new diagram checkbox. 

¶ Select the Automatically rename conflicting object names checkbox. 

¶ Clear the Paste report formats check box. 

¶ Clear the Paste event definitions checkbox. 

¶ Clear the Paste Objects only (no descriptors) checkbox. 

Click the OK button to open the Modify Options of Group Me mbers  form 

15.  In the Modify Options of Group Members  form 

In the Name Substitution group 

¶ In the Substitutes field, enter “03” 

In the Address substitution group 

In the Node field, enter “3ò to assign node no. 2 to all objects in the group. 

16.  Click the OK button to import the objects in to the Water Supply diagram. 

17.  Right-click the Water Supply diagram and select Properties . 

18.  In the Diagram Properties form 

In the Diagram Type group 

¶ Select the Reusable diagram option 

¶ Select PST01-GRP as control group 

Click the OK button to close the Diagram Properties form. 
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19.  Press F5 to refresh the Water Supply diagram. 

The three groups are displayed in the diagram.  

Select PST02-GRP and see how the object names change on the diagram. 

20.  Press F5 again and this time select PST01-GRP. 

 

The three Pump Stations now have their own objects in each group (PST01-GRP, 

PST02-GRP and PST03-GRP) and share a common diagram, which is reused to 

display the objects in the group you select. 

A new analog object must now be created for all the pump stations. You can do 

this by creating the object in one group and then updating the other groups to 

reflect the new object. 

Step Action 

1.  In the Water Supply diagram in the Definition form, click Objects > Create > By 

Object Type > Analog to open the Object Browser form. 

2.  In the left pane of the Object Browser form, expand the Training folder and 

select the Analog folder.  

3.  In the Create new object group in the name field, enter “PST01-q1” and click the 

Create button to open the PST01-q1 form. (object properties form) 

4.  In the PST01-q1 form , click the Analog tab 

¶ In the Description field, enter: “Flow water in” 

¶ In the Max. field, enter: “100” 

¶ In the Min. field, enter: ”0” 

¶ In the Decimal Point field, enter: “1” 

¶ Select the High Alarm checkbox and in the input field to the right of the 

High Alarm checkbox, enter : “95.0” 

¶ In the Actual Value field, enter : “62.0” 

¶ Select the Low Limit checkbox and in the input field to the right of the 

Low Limit checkbox, enter “19.0” 

Task 3: Use the 

Group Object to 

update the diagram 
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5.  In the PST01-q1 form, click the Edit Mapping tab.  

In the Atoms group, clear the High Limit, Set Point, and Low Alarm checkboxes. 

6.  In the PST01-q1 form, click the Edit Mapping  tab. 

Set up High Alarm properties: 

1) In the Atom group, select the High Alarm checkbox  

2) In the I/O Mode field select “Local” for the high alarm.  

3) In the Alarm Details  Group, select the ñ102: High Alarmò 

Set up Actual Value properties: 

1) In the Atom group, select the Actu al Value  checkbox  

2) In the I/O Mode field select ñinò for the actual value. 

3) In the PLC Node for object PST01 -q1 Group: 

a. Verify the Driver:  field contains the PLC driver we chose in 

System Configuration  “7TS7TCP (Demo Station) “ 

b. Verify the Node:  field value is “0ò. 

c. In the Data Block Number field, enter: “18” 

d. In the Offset  field, enter: “6” 

e. In the Bit Offset field, enter: “0” 

Set up Low Limit properties: 

1) In the Atom group, select the Low Limit checkbox 

2) In the I/O Mode field select “local” for the low limit.  

3) In the Alarm Details  Group, select the ñ103: Low Alarmò 

7.  In the PST01-q1 form, click the Data Management Definitions tab. 

¶ In the Scan interval Group, select the 2000 option. 

¶ In the Logging Group, select the All changes option 

¶ In the Base interval Group, select the 10 option 

¶ In the Data Reduction Group, select the Average  checkbox 

¶ In the Transfer to History Group, select the Reduced value checkbox 

8.  In the PST01-q1 form, click the Display tab. 

In the Show group: 

¶ In the Name sub-group, select the Enable checkbox. 

¶ In the State / Value sub-group, select the Enable checkbox.  

9.  In the PST01-q1 form, click the Symbol Definition  tab. 

In the Choose symbol  group: 
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In the Symbol table field, select Analog Elements and select the flow symbol 

(See below) 

Flow symbol: 
 

 

10.  Click the OK button to create the PST01-q1 analog object 

11.  Adjust the placement of PST01-q1 in the Water Supply diagram. 

12.  Once you have created the new analog object and placed it in the diagram, you 

can update the group definition, updating all the linked group objects at the 

same time by re-importing the group. 

In the Water Supply diagram, select the PST01-q1 analog object. 

Click Edit > Group Manager  to open the Group Manager  form. 

13.  In the left pane of the Group Manager  form, select the PST01-GRP folder and 

click the Add Selected Objects button. 

The PST01-q1 analog object is added to the right pane of the Group Manager  

form 

14.  In the Group Manager  form, click the Export button and overwrite the existing 

file, PST01-GRP.cgf . 

15.  In the Water Supply diagram in the Definitions form, click File > Reimport. 

Select all the checkboxes (PST01-Grp, PST02-GRP and PST03-GRP) you want to 

update with the re-import. 

Click the OK button to reimport the new group. 

16.  Press F5 to refresh the diagram and select PST02-GRP.  

The new object PST02-q1 appears at the position where you placed it in the 

Water Supply diagram. The same goes for the group PST03-GRP where PST03-

q1 has been created. 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE. 
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Exercise 11: Create Users and User Privileges 

Learn how to create new user groups, define their rights and assign users to the 

groups using the User Administration module. 

In this exercise, you will be using the IGSS Demo project again.  

20 - 25 minutes. 

You are to create three user groups but only need to create one user for each 

user group.  The three user groups are: 

¶ Admin: All the system administrators and supervisors, regardless of day 

or night shift. 

¶ OpDay: System Operators, Day shift 

¶ OpNight: System Operators, Night shift 

The table below displays the users, user groups and rights you need to set up in 

this exercise. 

User Administration Setup 

User group  Admin* OpDay OpNight 

Global rights  Can define 
Can administer 
Can use system 
commands 
Can define WinPager    
settings 

Can use system 
commands 

 

Protect 

object rights 

Protect - 4 Protect - 2 Protect - 1 

Default 

diagrams 

Area: Global 

Diagrams in area: Home 

Area: Training 

Diagrams in area: 

Pump Station 

Area: Global 

Diagrams in area: 

Home 

User name  Admin UserDay UserN 

Password Admin day night 

 

The Admin group already exists in the Demo project. You need edit the group 

though. 

 

Purpose 

Duration 
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You must first create the user groups in order to assign the users to the groups. 

You will later define the Protect Object security settings and create the users. 

Step Action 

1.  In the IGSS Master, click the Design and Setup tab > User Administration button 

to open the User Administration form. 

2.  In the User Administration form, click File > User Groups to open the User 

Groups form. 

3.  Create the OpDay user group: 

1) In the User Groups form, click the Add Group button.  

2) In the group list in the All defined groups group, select the group that is 

prefixed with a question mark and contains four numbers “?#### ”  

3) In the Group Name field, enter ”OpDay” 

4) In the Area field, select Training 

5) In the Diagrams in Area field, select the Pump Station checkbox  

6) In the Global rights group, select the Can use systems commands 

checkbox. 

7) In the Protect Object rights group, select the Global ς Protect ς 2 

checkbox 

4.  Create the OpNight user group: 

1) In the User Groups form, click the Add Group button.  

2) In the group list in the All defined groups group, select the group that is 

prefixed with a question mark and contains four numbers “?#### ”  

3) In the Group Rights field, verify that all the check boxes are selected. 

4) In the Area field, select Global 

5) In the Diagrams in Area field, select the Home checkbox  

6) In the Protect Object rights group, select the Global ς Protect ς 1 

checkbox 

Task 1: Create  

User groups 
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5.  Edit the Admin user group 

1) In the User Groups form in the group list in the All defined groups group, 

select the Admin user group.  

2) In the Area field, select Global 

3) In the Diagrams in Area field, select the Home checkbox 

4) In the Protect Object rights group, select the Global ς Protect ς 4 

checkbox 

6.  Click the Close button to save the user group settings, close the User Groups 

form and return to the User Administration form. 

 

 

Now we must set up the various Protect object levels to be used on individual 

objects in our project. 

The Protect object is a digital object where only one state can be active. So only 

level 1, 2, 3 or 4 can be the active protect level unless you select the Hierarchical 

check box for the relevant protect levels. 

Step Action 

1.  In the User Administration form, click File > Protect Objects to open the Protect 

Objects form. 

2.  If the Protect Objects form is empty, click the Update List button to reload the 

form and update the protect objects settings. 

3.  In the Protect Objects form in the List of Protect Objects field, select the Protect 

4 Global value. 

Select all the checkboxes: 

¶ Can acknowledge alarms 

¶ Can update set points 

¶ Can update alarm limits 

¶ Can send commands 

¶ Can update strings 

¶ Can update tables 

¶ Can open diagrams and areas 

Select the Hierarchial check box to enable the next lower Protect level.  

Normally only one protect level can be active, but when you select the 

Hierarchial check box, you simulate that all four protect levels are active at the 

Task 2: Setting up the 

Protect object rights 
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same time. 

4.  In the Protect Objects form in the List of Protect Objects field, select the Protect 

3 Global value. 

Clear  all the following checkboxes: 

¶ Can acknowledge alarms 

¶ Can update set points 

¶ Can update alarm limits 

¶ Can send commands 

¶ Can update strings 

¶ Can update tables 

¶ Can open diagrams and areas 

Select the Hierarchical  check box 

5.  In the Protect Objects form in the List of Protect Objects field, select the Protect 

2 Global value. 

Select the following checkboxes: 

¶ Can acknowledge alarms 

¶ Can update alarm limits 

¶ Can send commands 

Select the Hierarchical  check box 

6.  In the Protect Objects form in the List of Protect Objects field, select the Protect 

1 Global value. 

Select Can acknowledge alarms check box 

Select the Hierarchical  check box 

7.  Click on the Close  button to save the protect levels, close the Protect Objects 

form and return to the User Administration form. 

 

After you have set up the Protect object levels to be used on individual objects in 

our project, you must create the users and their passwords and assign the users 

to the relevant user groups. 

Step Action 

1.  In the User Administration form, click File > Users and Passwords to open the 

Users and Passwords form. 

2.  Create the UserDay user: 

Task 3: Create and 

assign users to user 

groups  
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1) In the Users and Passwords form, click the New User button.  

2) In the group list in the List of defined Users group, select the user that is 

prefixed with a question mark and contains four numbers “?#### ”  

3) In the User Name field, enter ”UserDay” 

4) In the Password field, clear the field and enter “day” 

5) In the Full name field, enter “User Day Shift” 

6) In the User group field, select OpDay user group 

Click the Add to Group button to assign the UserDay user membership of the 

OpDay user group. 

3.  Create the UserN user: 

1) In the Users and Passwords form, click the New User button.  

2) In the group list in the List of defined Users group, select the user that is 

prefixed with a question mark and contains four numbers “?#### ”  

3) In the User Name field, enter ”UserN 

4) In the Password field, clear the field and enter “night” 

5) In the Full name field, enter “User Night Shift” 

6) In the User group field, select OpNight user group 

Click the Add to Group button to assign the UserN user membership of the 

OpNight user group. 

Note 
You should only use short user names as you can only set user names of up to 

eight characters. The user name is not case-sensitive: “UserDay” is the same user 

as “userday” but the password is case-sensitive. 

4.  Click the Close button to save the user settings, close the Users and Passwords 

form and return to the User Administration form. 

5.  Close the User Administration form to return to the IGS S Master. 

 

After you have set up the users and user groups and defined the protect levels 

you must set up the security lock which is applied to individual objects in the 

project. The security lock is called the Protect  object and is always present in an 

IGSS project. 

 

Task 4:  

Set up the 

Protect object. 
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Step Action 

1.  In the IGSS Master, click Design and Setup tab > Definition button to open the 

Definition form. 

2.  In the Definition form, click Edit > Open by Name to open the Object Browser 

form. 

3.  In the left pane of the Object Browser form, expand the Global  / Digital  folder 

and select the PROTECT template in the Digital folder. 

4.  In the right pane of the Object Browser form, select the protect object. 

5.  In the Open by name  group, select the Show properties  check box and click the 

Open / Select button to open the Protect form (the object properties form for 

the Protect object). 

6.  In the Protect form, click the Change State  tab. 

In the States group, select the Set security level 4 option. 

Verify that the Open Access option is also selected in the Commands group. 

7.  Click the OK button to save the protect object security level settings and close the 

Protect form 

 

After you have set the security settings for the PROTECT template, you must now 

is ensure that the special Protect object is connected to the objects in the project 

for which we need extra security.  

You will be setting up object-level security for the p3 digital object (water pump) 

in the Refuse Disposal project and for the q3 analog object (flow tank 1) in the 

Dairy project. 

 

Step Action 

1.  In the Definition form, double-click IGSS training button > Refuse Disposal image 

to open the Refuse Disposal diagram. 

You can also click Area > Training and then Diagram > Refuse disposal  to open 

the Refuse Disposal diagram. 

2.  In the Refuse Disposal diagram, locate the p3 digital object (water pump)  

On the p3 digital object, right-click and select Properties to open the p3 ς Water 

Task 5: Connect the 

Protect object to 

project objects to be 

protected 
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pump form. 

Tip 
You can use the Object Browser form (Found in File > Object Browser) to search 

for and find the p3 digital object. 

3.  In the p3 ς Water pump form, click the Data Management Definitions  tab. 

In the Protection  field, select Protect  in the drop-down box . 

4.  Click the OK button to save the properties and exit the p3 ς Water pump form. 

5.  In the Refuse Disposal diagram, click Area > Training and then Diagram > Dairy to 

open the Dairy diagram. 

6.  In the Dairy diagram, locate the q3 analog object (q3 flow valve)  

On the q3 analog object, right-click and select Properties to open the q3 Flow 

Tank 1 form. 

Tip 
You can use the Object Browser form (Found in File > Object Browser) to search 

for and find the q3 analog object 

7.  In the q3 Flow Tank 1 form, click the Data Management Definitions  tab. 

In the Protection  field, select Protect  in the drop-down box. 

8.  Click the OK button to save the properties and exit the q3 Flow Tank 1 form. 

9.  In the Definition form, click File > Check and Install to install the changes you 

have made. 

 

User access control must be enabled for the user log on and object-level security 

to take effect in the project .  

You can enable user access control from the IGSS Master in the System 

Configuration form. The access control system is disabled by in IGSS.  

Step Action 

1.  In the IGSS Master, click Design and Setup tab > System Configuration button to 

open the System Configuration form. 

2.  In the System Configuration form, click the Access Control  tab. 

¶ Clear the Disable access control  checkbox. 

¶ Select the Allow permanent user login  checkbox 

Task 6: Enable User 

Administration 
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¶ Select the Save latest user logged in  checkbox 

3.  In the System Configuration form, click the Supervise & Language  tab. 

¶ In the Options group, select the Show active user in title bar (Classic 

Only) check box. 

4.  In the System Configuration form, click the Startup  tab. 

¶ In the Startup group, select the Manual option 

5.  In the System Configuration form, click the File  > Save and Exit . 

6.  Allow the system to re-start the IGSS Master and the demo project. 

 

Test the user profiles User Day and UserN in the Demo project, Training diagrams. 

You will log on as UserN and attempt to adjust the values of the p3 and q3 objects 

in the Dairy and Refuse Disposal diagrams. 

Step Action 

1.  In the IGSS Master, click the Home Tab > Stop button to stop the project.  

Once the project has stopped, click the Start button to start the project again.  

The Temporary Login  dialog box appears. 

2.  In the Temporary Login  dialog, log in as UserN  and “night”   

Verify that the User UserN does not have sufficient security rights to start the 

project. 

3.  In the Temporary Login  dialog, log in as UserDay and “day”   

The user UserDay has sufficient security rights start the project and the project 

starts. 

4.  In the IGSS Master, click > Home tab > Supervise  button. 

Verify that the Pump Station diagram is be opened. 

5.  In the Pump Station diagram, click File > Logout  to log out as UserDay. 

In the Pump Station diagram, click File > Login  and log in as UserN  

Verify that the Home diagram is displayed. 

Task 7: Test with 

User  

Administration 

enabled 
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6.  In the Home diagram, click IGSS Training button > Refuse Disposal image to open 

the Refuse disposal  diagram.  

In the Refuse disposal  diagram, click the STOP button under the p3 digital object 

(Water pump). 

Verify that the Temporary login dialog is displayed and you do not as UserN have 

sufficient security rights to stop the p3 object  (pump). 

What happens?  

Try to log in temporarily as UserDay and Admin. 

Who has the right to control the pump?  

7.  In the Refuse disposal  diagram, click the Back button to open the Training 

diagram. 

In the Training diagram, click the Dairy Production image to open the Dairy 

diagram. 

8.  In the Dairy diagram, locate the q3 analog object (Flow tank 1). 

Right-click the object q3 and select HA (High Alarm).  

Change the HA limit to “85”.  

Verify that the UserN does not have sufficient security rights to change the alarm 

settings on the q3 object  (water tank 1). 

9.  In the Dairy diagram, click File > Logout to log out as UserN 

In the Dairy diagram, click File > Log in and log in as UserDay 

Verify that the Pump Station diagram is displayed. 

10.  In the Pump Station diagram, click the Back button to open the Training Diagram. 

In the Training diagram, click the Dairy Production image to open the Dairy  

diagram.  

11.  In the Dairy diagram, locate the q3 object. 

Right-click the q3 object and select Acknowledge alarm.  

12.  In the Pump Station diagram, click File > Exit to return to the IGSS Master. 
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This exercise is optional. Complete this exercise only if you completed the 

previous exercises and there is surplus time to do this exercise. 

You need to set safe commands on the two p1 and p2 water pumps in the Dairy 

diagrams, defining different settings for the water pumps. In order to test the safe 

command set up, you will need to create an extra user and assign membership of 

the OpDay user group as well as change the default diagram for the OpDay user 

group. 

First you have to log on as Admin in order to access the User Administration form 

though. 

Step Action 

1.  In the IGSS Master, click Home tab > Logout to log out as the present user (Use 

Day from Test 7 above) 

In the IGSS Master, click Home tab > Login and log in as Admin. 

Verify that the admin user icon is displayed in the lower right hand corner of the 

IGS S Master. 

 

2.  In the IGSS Master, click the Design and Setup Tab > User Administration button 

to open the User Administration form. 

3.  In the User Administration form, click File > User Groups to open the User Groups 

form. 

In the User Groups form: 

1) In the All defined groups, select the OpDay group. 

2) In the Area field, select Training 

3) In the Diagrams in area field, select the Refuse checkbox and the Pump 

Station checkbox. 

4) Click the Close button to save the settings for the user group, close the 

User Groups form, and return to the User Administration form. 

4.  In the User Administration form, click File > Users and Passwords to open the 

User Administration form. 

In the User Administration form, create the new users: 

Task 8: Set Safe 

commands on 

objects 
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¶ UserDay2, password: “day2” 

Assign the user to the user group OpDay.  

Tip 
See the task 3 above for detailed steps how to create users. 

5.  In the User Administration form, click File > Exit to exit the User Administration 

form and save the new users. 

Remember to log in as Admin again (See Step 1 above) 

6.  In the IGSS Master, click Design and Setup > Definition to open the Definition 

form. 

7.  In the Definition form, double-click Training button > Refuse Disposal image to 

open the Refuse Disposal Diagram. 

8.  In the Refuse Disposal Diagram, locate and right-click the p1 digital object.  

Select Properties to open the p1 ςPump water form and click the Data 

Management Definitions tab. 

9.  In the Data Management Definitions tab, in the Safe Commands field, select 

Confirm  

Click the OK button to exit the p1 ςPump water form. 

10.  In the Refuse Disposal Diagram, locate and right-click the p2 digital object.  

Select Properties to open the p2 ςPump water form and click the Data 

Management Definitions tab. 

11.  In the Data Management Definitions tab, in the Safe Commands field, select 

Conf. Password  

Click the OK button to exit the p2 ςPump water form. 

12.  In the Refuse Disposal Diagram, locate and right-click the p3 digital object.  

Select Properties to open the p3 ςPump water form and click the Data 

Management Definitions tab. 

13.  In the Data Management Definitions tab, in the Safe Commands field, select 

Conf. 2 users  

Click the OK button to exit the p3 ςPump water form. 

Note 
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The object-level protection on the p3 object is still active.  

To test the combination of Object-level protection and Safe commands, you can 

log on as UserN after this exercise and try to change the value of the p3 digital 

object. 

14.  In the Refuse Disposal diagram, click File > Check and Update (or Check and 

Install if you have stopped the project) to install your changes and exit the Refuse 

Disposal diagram. 

15.  In the IGSS Master, click Home tab > Logout to log out as the admin 

In the IGSS Master, click Home tab > Login and log in as UserDay. 

16.  In the IGSS Master, click Home > Supervise to open the Refuse Disposal diagram. 

17.  In the Refuse Disposal diagram, change the value of the p1 object. 

Verify a dialog box is displayed prompting you to accept the change. 

18.  In the Refuse Disposal diagram, change the value of the p2 object. 

Verify a dialog box is displayed prompting for your password in order to accept 

the change. 

19.  In the Refuse Disposal diagram, change the value of the p3 object. 

Verify a dialog box is displayed prompting for your password and another user’s 

password to accept the change in the Performed by group. 

Use the user UserDay2 to fill out the Verified by group and accept the change. 

20.  In the Refuse Disposal diagram, click File > Exit to return to the IGSS Master 

21.  (Optional step – compressed instructions) 

You can quickly reset the Safe Commands settings in the p1, p2 and p3 digital 

objects by using the Property Table view.  

In the Definition form, right-click the Refuse Disposal diagram and select Property 

Table viewer. 

In the left pane of the Property Table view form, in the Objects folder, select the 

p1, p2 and p3 digital objects and change the value in the Safe Command column 

to “(None)” 

Remember to log on as Admin if you are going to open the Definition form. 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE  
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Exercise 12: Create Maintenance Jobs 

Learn how to create maintenance jobs for analog and digital objects. We will try 

three of the four maintenance job types:  

¶ Periodical (q1) 

¶ Changes (p1) 

¶ Used time (p3) 

20 - 30 minutes. 

 

Before the maintenance jobs are created in the Maintenance form, you first need 

to create the alarm texts we need in the Definition form. 

Remember to change user to Admin so you can open the Definition form. 

 

Step Action 

1.  In the Definition form, Click Edit  > Alarm  Texts  to open the Alarm Details  form. 

2.  In the Alarm Details  form, click the New button to open the Edit Alarm 

Description form. 

In the Edit Alarm Description form, create alarm text for the maintenance alarm 

for the Periodical maintenance job type for the q1 analog object: 

¶ In the Alarm Text field, enter “Calibrate flow sensor” 

¶ In the Acknowledge color group, click the Change button and select a 

light red color. 

¶ In the Acknowledge color group, clear the Blink check box 

¶ In the Instructions field, enter “Use Calibrator AB 1001” 

¶ Note the alarm number: 

3.  Click the OK button to save the alarm text and return to the Alarm Details  form. 

Purpose 

Duration 

Task 1: Create 

maintenance 

alarm texts in 

Definition 
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4.  In the Alarm Details  form, click the New button to open the Edit Alarm 

Description form. 

In the Edit Alarm Description form, create alarm text for the maintenance alarm 

for the User Time maintenance job type for the p2 digital object: 

¶ In the Alarm Text field, enter “Lubricate pump bearings” 

¶ In the Acknowledge color group, click the Change button and select a 

light red color. 

¶ In the Acknowledge color group, clear the Blink check box 

¶ In the Instructions field, enter “Use the green lube tube for optimal 

lubrication” 

¶ Note the alarm number: 

5.  Click the OK button to save the alarm text and return to the Alarm Details  form. 

6.  In the Alarm Details  form, click the New button to open the Edit Alarm 

Description form. 

In the Edit Alarm Description form, create alarm text for the maintenance alarm 

for the Changes maintenance job type for the p1 digital object 

¶ In the Alarm Text field, enter “Visually inspect rotating parts” 

¶ In the Acknowledge color group, click the Change button and select a 

light red color. 

¶ In the Acknowledge color group, clear the Blink check box 

¶ In the Instructions field, enter “Make sure you’re inspecting all rotating 

parts” 

¶ Note the alarm number: 

7.  Click the OK button to save the alarm text and return to the Alarm Details  form. 

8.  In the Alarm Details  form, click the Close button to save the alarm texts and exit 

the form. 

9.  In the Definition form, click File > Check and Update (or Check and Install) to 

save and install the project. 
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Before the maintenance jobs can be created, you need to ensure that the 

Maintenance form is running when the IGSS application is started. 

 

Step Action 

1.  In the IGSS Master, click Design and Setup > System Configuration button to 

open the System Configuration form. 

2.  In the System Configuration form, click the Applications tab and select the Auto 

start in normal mode  checkbox in the Maintenance  row. 

3.  In the System Configuration form, click File  > Save and Exit  

4.  The Maintenance form is started automatically when the IGSS program starts. 

 

For the flow sensor we want to create a Periodical maintenance job that ensures 

that the flow sensor is calibrated every 60th day. Because we want to see the 

maintenance alarm right now, we create it as 2 minutes instead. 

 

Step Action 

1.  Open the Maintenance form and click Configuration tab > New Job button. 

2.  In the Job type  group, select Periodical . 

3.  In the object list, type “q” to go to the first object starting with q which is “q1”. 

Select the q1 analog object and click the OK button to open the New periodical 

Job (q1) form. 

4.  In the New periodical Job (q1) form, clear the Title field. 

5.  In the Maintenance interval group in the Periodical interval  field, select “2” and 

“minutes”  

6.  Under Alarm fired when job is due , select the “Calibrate flow sensor” alarm text 

created in Task 1.  

7.  Click the Use Alarm Text button to insert the alarm text title as the title of this 

maintenance job. 

Task 2: Start 

Supervise and 

Maintenance 

Task 3: Create 

Periodical 

maintenance job 
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8.  On the Job Description tab, type a filename for the maintenance job description 

(for example, “q1_cal_sensor.txt”)  

In the input field under the Filename field, enter “When you calibrate the sensor, 

make sure you’re using Calibrator AB 1001.”  

Click the OK button to create the new maintenance job.  

The new maintenance job now appears in the All Maintenance Jobs list. 

 

For the p1 water pump we want to create a Changes maintenance job where we 

ensure the rotating parts of the pump are visually inspected after 1,000 state 

changes. We do not have time to wait for 1,000 changes, so use 5 state changes 

instead of 1,000. 

 

Step Action 

1.  Open the Maintenance form and click Configuration tab > New Job button. 

2.  In the Job type  group, select Changes . 

3.  In the object list, type  ”p” to go to the first object starting with p which is “p1”. 

Select the p1 digital object and click the OK button to open the New periodical 

Job (p1) form. 

4.  In the New periodical Job (p1) form, clear the Title field. 

5.  In the Maintenance interval  group, in the Job due after  field, enter “5”. 

6.  In the Count on state change to (0) input field, select the OFF and ON check 

boxes as we want to count every change between the two states. 

7.  In the Alarm fired when job is due  field, select the “Visually inspect rotating 

parts” alarm text created in Task 1. 

8.  Click the Use Alarm Text button to insert the alarm text title as the title of this 

maintenance job. 

Task 4: Create 

Changes 

maintenance job 
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9.  In the Maintenance form, click the File tab. 

1) Click the Browse button to open the Open Job Link dialog. 

2) In the Open Job Link dialog, select All Files (*.*) in the lower right hand 

corner of the dialog. 

3) Navigate to the \ Gss \ Eng subfolder of your installation path and select 

the file GetStart .pdf . 

4) Click the Open  button to create a link to the document. 

The operator will then be able to view this manual to read the maintenance 

instructions. The IGSS Getting Started manual is used as an example of referring 

to the component manufacturer’s documentation file. 

10.  Click the OK button to create the new maintenance job.  

The new maintenance job now appears in the All Maintenance Jobs list. 

 

For the p3 water pump we want to create a Used Time maintenance job where 

we ensure the water pump is lubricated after 1,000 hours of use.  

We do not have time to wait for 1,000 hours, so use 2 minutes instead of 1,000 

hours. 

Step Action 

1.  Open the Maintenance form and click Configuration tab > New Job button. 

2.  In the Job type  group, select Used Time . 

3.  In the object list, type ”p” to help find the p3 object 

Select the p3 digital object and click the OK button to open the New periodical 

Job (p3) form. 

4.  In the New periodical Job (p3) form, clear the Title field. 

5.  In the Maintenance interval  group, in the Job due after  field, enter “2” “minutes” 

In the When job completed group, select the Next job after option and enter “15” 

to schedule the next and subsequent maintenance jobs for 15 minute intervals 

after the first maintenance. 

6.  In the States (0) input field, select the ON check box as we only want to sum the 

operation time when the pump is running. 
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7.  In the Alarm fired when job is due  field, select the “Lubricate pump bearings” 

alarm text created in Task 1. 

8.  Click the Use Alarm Text button to insert the alarm text title as the title of this 

maintenance job. 

9.  In the Maintenance form, click the Help File tab. 

1) Click the Browse button to open the Open Job Link dialog. 

2) In the Open Job Link dialog, select All Files (*.*) in the lower right 

hand corner of the dialog. 

3) Navigate to the \ Gss \ Eng subfolder of your installation path and 

select the file Maintenance.chm. 

4) Click the Open  button to create a link to the document. 

10.  Click the OK button to create the new maintenance job.  

The new maintenance job now appears in the All Maintenance Jobs list. 

 

In this last task, we’ll handle the maintenance alarms that will result from the 

maintenance jobs we just created. Remember that the maintenance alarm will 

occur in two contexts: in the Alarm List (because we attached an alarm text) and 

in the Maintenance List. 

 

Step Action 

1.  In the IGSS Master, click Home tab > Alarm button to open the Active Alarms 

form. 

2.  In the Active Alarms form, find and select the alarm which was originated from 

the maintenance job for either the q1 or p1 or p3 objects. 

In the workspace pane of the Active Alarms form, sight-click the alarm and select 

Acknowledge. 

3.  In the IGSS Master, click Home tab > Maintenance button to open the 

Maintenance form. 

In the Maintenance form, select the Maintenance Jobs Due  filter and select the 

maintenance job you acknowledged in the previous step. 

In the Maintenance form, click Configuration tab > Edit Information button to 

display the Job Information form and read any operator instructions.  
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4.  Click the OK button to close the Job Information form when you have read the 

instructions. 

5.  In the Maintenance form, click Job Handler tab > Complete button to register 

successful resolution of the maintenance job.  

The maintenance job will now be moved to the All Maintenance Jobs list. 

6.  (Optional Step – add a note) 

In the Maintenance job list in the Job handler tab > Maintenance Jobs due filter, 

select another maintenance job. 

In the Job Handler tab, click Open Job Note button and enter a text in the note 

pane. 

Close the note pane and verify that a note icon is attached to the selected 

maintenance job. 

 

YOU HAVE SUCCESSFULLY COMPLETED THE EXERCISE !! 


